Bug 502176 - synaptics stopped working after upgrade to xorg-x11-drv-synaptics-1.1.0-7.fc11.x86_64
synaptics stopped working after upgrade to xorg-x11-drv-synaptics-1.1.0-7.fc1...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 07:00 EDT by Milos Jakubicek
Modified: 2009-05-22 19:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-22 19:54:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (25.96 KB, text/plain)
2009-05-22 07:00 EDT, Milos Jakubicek
no flags Details
HAL fdi configuration (455 bytes, application/xml)
2009-05-22 07:01 EDT, Milos Jakubicek
no flags Details
HAL fdi configuration (456 bytes, application/xml)
2009-05-22 07:26 EDT, Milos Jakubicek
no flags Details

  None (edit)
Description Milos Jakubicek 2009-05-22 07:00:37 EDT
Created attachment 345078 [details]
Xorg log

Description of problem:

(II) config/hal: Adding input device SynPS/2 Synaptics TouchPad
(II) Synaptics touchpad driver version 1.1.0
(**) Option "Device" "/dev/input/event6"
(**) Option "SHMConfig" "true"
(**) Option "UpDownScrolling" "1"
(**) Option "TapButton1" "1"
(--) SynPS/2 Synaptics TouchPad: no supported touchpad found
(EE) SynPS/2 Synaptics TouchPad Unable to query/initialize Synaptics hardware.
(EE) PreInit failed for input device "SynPS/2 Synaptics TouchPad"
(II) UnloadModule: "synaptics"

I'm attaching my full log and HAL fdi file.

Version-Release number of selected component (if applicable):

xorg-x11-drv-synaptics-1.1.0-7.fc11.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Start X
  
Actual results:

Touchpad works but without tapping, scrolling and other features set up in HAL fdi.

Expected results:

Tapping and scrolling should work as before.
Comment 1 Milos Jakubicek 2009-05-22 07:01:55 EDT
Created attachment 345079 [details]
HAL fdi configuration
Comment 2 Milos Jakubicek 2009-05-22 07:26:30 EDT
Created attachment 345081 [details]
HAL fdi configuration

There was a typo in the previous xml (not related to this problem, imho: VertEdgeSroll => VertEdgeScroll)
Comment 3 Milos Jakubicek 2009-05-22 07:27:19 EDT
Just tried: downgrading to 1.1.0-6 makes the touchpad fully working again.
Comment 4 Peter Hutterer 2009-05-22 19:54:04 EDT
you have an xorg.conf section for the synaptics touchpad, and this configuration has precendence (since 1.1.0-5).
once the xorg.conf device has been set up, future synaptics devices on the same event file (such as the one provided through hal) will fail to initialize.

If you remove the device from the config, everything should work as expected.

Note You need to log in before you can comment on or make changes to this bug.