Bug 502207 - consider switching from ExcludeArch to ExclusiveArch
consider switching from ExcludeArch to ExclusiveArch
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libx86 (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Garrett
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2009-05-22 11:02 EDT by Dan Horák
Modified: 2009-11-17 14:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-17 14:44:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2009-05-22 11:02:54 EDT
If I understand the library it is meant to be used on i?86 and x86_64 platforms only. If I am right then it is more efficient to use ExclusiveArch because in current situation every secondary arch must add an exception into the ExcludeArch.

this is the suggested form:
ExclusiveArch %{ix86} x86_64
Comment 1 Bug Zapper 2009-06-09 12:20:43 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Adam Jackson 2009-11-17 14:44:49 EST
No, this package should build (and work) on all arches.  That it doesn't is an entirely separate pile of bugs.

Note You need to log in before you can comment on or make changes to this bug.