Bug 502218 - strace: malloc.c:3552: mremap_chunk: Assertion `((size + offset) & (mp_.pagesize-1)) == 0' failed.
strace: malloc.c:3552: mremap_chunk: Assertion `((size + offset) & (mp_.pages...
Status: CLOSED DUPLICATE of bug 511035
Product: Fedora
Classification: Fedora
Component: strace (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Roland McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 11:47 EDT by Orion Poplawski
Modified: 2009-08-18 12:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-18 12:02:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-05-22 11:47:40 EDT
Description of problem:

Seeing this when tracing a proprietary java application during application shutdown:

strace: malloc.c:3552: mremap_chunk: Assertion `((size + offset) & (mp_.pagesize-1)) == 0' failed.

Version-Release number of selected component (if applicable):
strace-4.5.18-2.fc11.x86_64
Comment 1 Bug Zapper 2009-06-09 12:21:22 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Michal Nowak 2009-08-14 10:45:53 EDT
Orion, I'd probably ask you to work with upstream on this, I am afraid we won't do much about it in here.
Comment 3 Andreas Schwab 2009-08-18 12:02:42 EDT

*** This bug has been marked as a duplicate of bug 511035 ***

Note You need to log in before you can comment on or make changes to this bug.