Bug 502220 - R2spec emits a nil Requires line in some cases
R2spec emits a nil Requires line in some cases
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: R2spec (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 11:49 EDT by R P Herrold
Modified: 2009-07-25 08:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-25 08:31:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2009-05-22 11:49:22 EDT
Description of problem:

R2spec emits a nil Requires line in some cases

Version-Release number of selected component (if applicable):

$ rpm -q R2spec
R2spec-2.5.2-1orc

How reproducible:

run: R2spec --cran -u http://r-forge.r-project.org/src/contrib/colbycol_0.1.tar.gz

Steps to Reproduce:
  
line 16 is nil as to a RHS

Actual results:

as above

Expected results:

suppress nil Require lines

Additional info:

There is a python sub-element packaging issue as well, but this is out of scope here, as it is probably an extension to the package

error: File not found: /var/tmp/R-colbycol-0.1-1orc-root-herrold/usr/share/R/library/colbycol/doc
error: File not found: /var/tmp/R-colbycol-0.1-1orc-root-herrold/usr/share/R/library/colbycol/NEWS
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/R-colbycol-0.1-1orc-root-herrold
error: Installed (but unpackaged) file(s) found:
   /usr/share/R/library/colbycol/python/colbycol.py
   /usr/share/R/library/colbycol/python/colbycol.pyc
   /usr/share/R/library/colbycol/python/colbycol.pyo


RPM build errors:
    File not found: /var/tmp/R-colbycol-0.1-1orc-root-herrold/usr/share/R/library/colbycol/doc
    File not found: /var/tmp/R-colbycol-0.1-1orc-root-herrold/usr/share/R/library/colbycol/NEWS
    Installed (but unpackaged) file(s) found:
   /usr/share/R/library/colbycol/python/colbycol.py
   /usr/share/R/library/colbycol/python/colbycol.pyc
   /usr/share/R/library/colbycol/python/colbycol.pyo
[herrold@centos-5 colbycol]$
Comment 1 Pierre-YvesChibon 2009-06-03 08:01:24 EDT
(In reply to comment #0)
> Expected results:
> 
> suppress nil Require lines

This is done for the next release

> 
> Additional info:
> 
> There is a python sub-element packaging issue as well, but this is out of scope
> here, as it is probably an extension to the package
> 
> error: File not found:
> /var/tmp/R-colbycol-0.1-1orc-root-herrold/usr/share/R/library/colbycol/doc
> error: File not found:
> /var/tmp/R-colbycol-0.1-1orc-root-herrold/usr/share/R/library/colbycol/NEWS
> Checking for unpackaged file(s): /usr/lib/rpm/check-files
> /var/tmp/R-colbycol-0.1-1orc-root-herrold
> error: Installed (but unpackaged) file(s) found:
>    /usr/share/R/library/colbycol/python/colbycol.py
>    /usr/share/R/library/colbycol/python/colbycol.pyc
>    /usr/share/R/library/colbycol/python/colbycol.pyo
> 
> 

This is IMHO linked to the fact that I didn't find (yet ?) a way to predict the content of the package based on the source.
This is one of the reason why it's R2spec not (yet ?) R2rpm ;-)

If you have any idea on how to fix this issue, please feel free :)
Comment 2 Bug Zapper 2009-06-09 12:21:39 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 R P Herrold 2009-07-14 11:00:38 EDT
hold open in RawHide, as it is not yet addressed

Note You need to log in before you can comment on or make changes to this bug.