Bug 502225 - java.util.zip.ZipException trying to launch JNLP file from Supermicro KVM
java.util.zip.ZipException trying to launch JNLP file from Supermicro KVM
Status: CLOSED DUPLICATE of bug 480075
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 12:10 EDT by Jason Tibbitts
Modified: 2009-06-24 22:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 22:13:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Tibbitts 2009-05-22 12:10:37 EDT
It's tough to come up with a summary for this one.

Basically, I have a Supermicro system with an embedded WPCM450 management controller that provides KVM over IP via a java application deployed with a JNLP file.  I believe Dell is using the same management controller in their newer products.

You click on a button, the browser gets a JNLP file and asks what to do with it.  Rawhide offers to open in IcedTea webstart, which starts up NetX, downloads various jars and aborts with:

net.sourceforge.jnlp.LaunchException: Fatal: Launch Error: Could not launch JNLP file.
        at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:372)
        at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
Caused by: java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(ZipFile.java:131)
        at java.util.jar.JarFile.<init>(JarFile.java:150)
        at java.util.jar.JarFile.<init>(JarFile.java:114)
        at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:345)
        ... 1 more
Caused by:
java.util.zip.ZipException: error in opening zip file
        at java.util.zip.ZipFile.open(Native Method)
        at java.util.zip.ZipFile.<init>(ZipFile.java:131)
        at java.util.jar.JarFile.<init>(JarFile.java:150)
        at java.util.jar.JarFile.<init>(JarFile.java:114)
        at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:345)
        at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)

However, I can't figure out which zip file is problematic, or what is supposedly wrong with it.  The files look OK to me when I download them manually and unzip them.  I also tried with F10 but the behavior is unchanged, so this doesn't seem to be a regression.

I can verify that Sun java seems to have no problem opening these files.

Unfortunately I'm not sure what information I can supply.  I saved the JNLP file and the jars it references in http://www.math.uh.edu/~tibbs/java-problem.  I can put the management console of one of these systems on the public Internet and provide a login if someone's interested in debugging it that way.

Just doing some more debugging, I see that netx seems to have created a file JViewer.jar.info in /tmp/cache containing:

#automatically generated - do not edit
#Fri May 22 11:06:19 CDT 2009
last-modified=0
content-length=-1
last-updated=1243008379527

I can't see that it actually downloaded any of the jars, however.
Comment 1 Jason Tibbitts 2009-05-22 12:52:58 EDT
I believe this may be bug 480075, given that https is involved and I haven't bothered setting up the SSL stuff for this host yet.
Comment 2 Bug Zapper 2009-06-09 12:21:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Jason Tibbitts 2009-06-24 22:13:49 EDT
I just noted that this is still open.  It seems that it is/was indeed a dup of 480075.

*** This bug has been marked as a duplicate of bug 480075 ***

Note You need to log in before you can comment on or make changes to this bug.