Bug 502252 - X crashes while viewing a large image in Firefox
X crashes while viewing a large image in Firefox
Status: CLOSED DUPLICATE of bug 498131
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-22 15:36 EDT by Todd J Martin
Modified: 2009-05-22 17:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-22 17:39:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Full gdb backtrace (5.43 KB, text/plain)
2009-05-22 15:36 EDT, Todd J Martin
no flags Details
Xorg.0.log (31.12 KB, text/plain)
2009-05-22 15:37 EDT, Todd J Martin
no flags Details

  None (edit)
Description Todd J Martin 2009-05-22 15:36:24 EDT
Created attachment 345151 [details]
Full gdb backtrace

Description of problem:

The X server will sometimes crash (bus error) when Firefox is used to view large images.

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.6.1.901-1.fc11.i586
xorg-x11-drv-intel-2.7.0-4.fc11.i586
firefox-3.5-0.20.beta4.fc11.i586


How reproducible:

This happens on my Thinkpad T500 which has an Intel Mobile 4 Integrated Graphics controller.  There is no xorg.conf file.

Go to some website with very large images and use Firefox to view the images.


Actual results:

The server gets a bus error and crashes.  This is intermittent so large images often display correctly, but I can generally make this happen with less than 30 minutes of concerted browsing of large images.

From the end of the Xorg.0.log:

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3b) [0x812d07b]
1: /usr/bin/X(xf86SigHandler+0x9e) [0x80c061e]
2: [0x90d400]
3: /usr/lib/libpixman-1.so.0 [0x272fed0]
4: /usr/lib/libpixman-1.so.0(pixman_blt+0xfa) [0x27255ba]
5: /usr/lib/xorg/modules//libfb.so(fbCopyNtoN+0x1aa) [0x2203da]
6: /usr/lib/xorg/modules//libfb.so(fbCopyRegion+0x21b) [0x21f41b]
7: /usr/lib/xorg/modules//libfb.so(fbDoCopy+0x44d) [0x21f93d]
8: /usr/lib/xorg/modules//libfb.so(fbCopyArea+0x78) [0x21fb48]
9: /usr/lib/xorg/modules/drivers//intel_drv.so [0x1c7cca]
10: /usr/lib/xorg/modules/drivers//intel_drv.so [0x1c807d]
11: /usr/bin/X [0x8179030]
12: /usr/bin/X(ProcPutImage+0x159) [0x8083809]
13: /usr/bin/X(Dispatch+0x347) [0x80864d7]
14: /usr/bin/X(main+0x395) [0x806baf5]
15: /lib/libc.so.6(__libc_start_main+0xe6) [0x2c4a66]
16: /usr/bin/X [0x806afa1]

Fatal server error:
Caught signal 7.  Server aborting


Expected results:

X should not crash.

Additional info:

I installed the appropriate debuginfo rpms and reproduced this with gdb attached to the X server.  The full backtrace is attatched.

The Xorg.0.log is also attached.
Comment 1 Todd J Martin 2009-05-22 15:37:13 EDT
Created attachment 345152 [details]
Xorg.0.log
Comment 2 Kristian Høgsberg 2009-05-22 17:39:37 EDT

*** This bug has been marked as a duplicate of bug 498131 ***

Note You need to log in before you can comment on or make changes to this bug.