This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 502258 - services autostarted by dbus don't get $XDG_SESSION_COOKIE
services autostarted by dbus don't get $XDG_SESSION_COOKIE
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-xinit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11Target
  Show dependency treegraph
 
Reported: 2009-05-22 16:11 EDT by Nalin Dahyabhai
Modified: 2009-07-16 03:25 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.0.9-9.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-16 03:25:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for ck-xinit-session to have it tell the bus about $XDG_SESSION_COOKIE (2.81 KB, patch)
2009-05-22 16:11 EDT, Nalin Dahyabhai
no flags Details | Diff

  None (edit)
Description Nalin Dahyabhai 2009-05-22 16:11:27 EDT
Created attachment 345158 [details]
patch for ck-xinit-session to have it tell the bus about $XDG_SESSION_COOKIE

Description of problem:
Even with xorg-x11-xinit-1.0.9-7, when I plug in a removable device, I get an access-denied error (org.freedesktop.devicekit.disks.filesystem-mount) if my session was started with 'startx'.

Version-Release number of selected component (if applicable):
1.0.9-7

How reproducible:
Always

Steps to Reproduce:
1. Boot to runlevel 3.
2. Log in.
3. 'startx'
4. Plug in a USB thumbdrive.
  
Additional info:
This appears to be happening because gvfs-gdu-volume-monitor is autostarted by the session bus daemon, which started before we had the right session cookie, which causes it to not be seen as part of the active session.
Comment 1 Bug Zapper 2009-06-09 12:23:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Fedora Update System 2009-06-15 22:11:38 EDT
xorg-x11-xinit-1.0.9-9.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-xinit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6320
Comment 3 Fedora Update System 2009-07-16 03:25:06 EDT
xorg-x11-xinit-1.0.9-9.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.