Bug 502276 - Radeon Mobility X1600 not working with radeon
Radeon Mobility X1600 not working with radeon
Status: CLOSED DUPLICATE of bug 468773
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-05-22 21:33 EDT by Bill McGonigle
Modified: 2014-01-21 18:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-06-22 12:14:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill McGonigle 2009-05-22 21:33:20 EDT
Description of problem:

The upgrade process should know about when a user needs to change something to keep their hardware working.  e.g. X Servers

Version-Release number of selected component (if applicable):

f10 version of preupgrade

How reproducible:


Steps to Reproduce:
1. upgrade from f10 to f11-rawhide
Actual results:

system broken (X fails to start upon final reboot)

Expected results:

system still works! (X starts with correct server)

Additional info:

my hardware (radeon mobility x1600) apparently went from being supported by 'radeon' to being supported by 'radeonhd'.  I know how to read Xorg.0.log and edit xorg.conf but most users would just say the upgrade broke their system.  Perhaps an assumption in the first stages could be sanity tested against later stages where autodetection is available.
Comment 1 Bug Zapper 2009-06-09 12:24:29 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
Comment 2 Kevin Kofler 2009-06-09 18:52:48 EDT
The hardware is supposed to still be supported by "radeon", the fact that it doesn't work is a bug. Switching to "radeonhd" is not the correct fix.
Comment 3 Matěj Cepl 2009-06-10 06:41:24 EDT
We never use radeonhd without users explicit request. There must be something weird somewhere.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 4 Matěj Cepl 2009-06-22 12:14:14 EDT

*** This bug has been marked as a duplicate of bug 468773 ***

Note You need to log in before you can comment on or make changes to this bug.