Bug 502283 - Faint sound in Fedora 11 pre release [Intel HDA 1025:0121]
Faint sound in Fedora 11 pre release [Intel HDA 1025:0121]
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-utils (Show other bugs)
rawhide
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlsaVolume
  Show dependency treegraph
 
Reported: 2009-05-23 01:06 EDT by Narasimhan
Modified: 2009-06-12 12:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-02 13:05:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
amixer before trying the fix (2.38 KB, text/plain)
2009-05-23 01:07 EDT, Narasimhan
no flags Details
amixer output after fix (2.38 KB, text/plain)
2009-05-23 01:08 EDT, Narasimhan
no flags Details
alsa info (23.64 KB, text/plain)
2009-05-23 01:08 EDT, Narasimhan
no flags Details

  None (edit)
Description Narasimhan 2009-05-23 01:06:24 EDT
Description of problem:
When playing an audio or video file with music in F11 pre release, the sound is faint even if the volume settings in the gnome sound applet is set to full.
I am using laptop speakers and S/PDIF digital output to a 4 in 1 speaker

Version-Release number of selected component (if applicable):
rawhide

How reproducible:
Install F11 pre release. Play an audio file. Even if the sound volume in the sound applet is set to full, the sound is faint. 

Steps to Reproduce:
1.Install F11 pre release
2.Play an audio file. 
3.Check that  the volume in sound applet is full
  
Actual results:
The increase in volume should result in louder sound

Expected results:
The sound is still faint

Additional info:
Running alsamixer -c0 as mentioned in this link http://forums.fedoraforum.org/showthread.php?t=219281&page=3 , I found that the levels in "front"  column was arnd 30 % . I increased it to full and the sound becomes louder. This was exactly how it used to be on my system using fedora 10.
Comment 1 Narasimhan 2009-05-23 01:07:35 EDT
Created attachment 345176 [details]
amixer before trying the fix
Comment 2 Narasimhan 2009-05-23 01:08:03 EDT
Created attachment 345177 [details]
amixer output after fix
Comment 3 Narasimhan 2009-05-23 01:08:44 EDT
Created attachment 345178 [details]
alsa info
Comment 4 Adam Williamson 2009-05-25 15:17:14 EDT
I'm not sure the attachments show the correct change: they only show an increase in the 'Master' control and a decrease in the 'PCM' control. The 'Front' control is at 100% in both cases.

When you increase the Front control to 100%, does the volume control slider in the GNOME volume control applet still give you a good volume range? i.e. with the GNOME volume control slider at 0 you hear nothing, at a low level the volume is quiet, and at a high level it's loud?

Thanks.
Comment 5 Narasimhan 2009-05-26 02:00:19 EDT
I used alsamixer -c0 to correct the sound issue, so the report shows that Front is 100%.

Yes. 

Initially after my install of Fedora 11, I increased the master volume to 100 (using the panel applet) but still the sound was faint. I used the alsamixer -c0 command and saw that pcm was more than 80% but front was less than 20 %. No matter how much I adjust master, its not useful without front slider being below 20% . So I made it full. After this, any adjustment I make in the sound applet reflects the change in master volume only.

On the same hardware, when I was using Fedora 10, I would always set the Front to 100 % (using the gst mixer). Without that even if I set master and pcm to 100, the sound will be faint.

The above is what I could remember but I do not have the laptop at this moment. I will have it with me on friday. I can do the test by adjusting the front volume and I will confirm the behavior on friday. Is that ok? Because I want to be absolutely sure before we can reach any conclusions.

Thanks...
Comment 6 Adam Williamson 2009-05-26 03:06:00 EDT
That's fine - the main important point is whether you can still get a full useful volume range from the Master slider, when Front is set to 100. That's an important issue. If you do, we can just set Front to 100 by default.
Comment 7 Narasimhan 2009-05-29 09:17:48 EDT
I have confirmed the behaviour that if I keep my front to 100, I can still use master slider to control the volume to be either  at mute(zero) or full to get loud sound.
Comment 8 Adam Williamson 2009-05-29 12:14:48 EDT
Great. Jaroslav, looks like the Front control should default to 100 for this chip.
Comment 9 Jaroslav Kysela 2009-06-01 03:21:02 EDT
Front should be set to 0dB in current configuration. Could you verify if 'alsactl init' command initializes Front volume to 0dB (100%)?
Comment 10 Narasimhan 2009-06-01 10:55:11 EDT
I switched to root. Modified the front volume to be 20% using alsamixer -c0. I ran alsactl init . Verified using alsamixer that front slider is set to 100%, PCM to 100% and Master to 55%
Comment 11 Adam Williamson 2009-06-01 14:05:12 EDT
and at that point, does sound work correctly? you can control volume usefully with the PA slider?
Comment 12 Narasimhan 2009-06-02 02:22:57 EDT
Yes. Now I can use the pusleaudio sound applet to control the volume (which is  changing the master slider).This is exactly what I had with fedora 10 where I would set Front slider to be 100% and use the gnome volume applet to control the Master slider.However in fedora 10 when I  open the mixer dialog I would also get the Front slider which is not the case now.
Comment 13 Adam Williamson 2009-06-02 13:05:01 EDT
Sounds like this is fixed, then (it's normal that you only get one volume slider in g-v-c). Closing. Thanks for the report.
Comment 14 Narasimhan 2009-06-03 01:21:02 EDT
Is the fix for this bug going to be available in fedora 11 final release ,so that if I install Fedora 11 final afresh on my laptop I will not see any difference in the sound loudness from Fedora 10. I have my home directory on a separate partition so all of gnome's settings will still be applicable after the install. If I had set the master volume to say 90 % and front slider to 95%, will it still be case once I install Fedora 11.
Comment 15 Adam Williamson 2009-06-03 16:41:56 EDT
well, your preferred sound levels aren't saved in your home directory, so no. On a fresh install it should be set to the values you got after running 'alsactl init' - those are the default values. Once you set it to your preferred levels once, they'll be saved for the future.

the values are saved to /etc/asound.state at shutdown, and restored from there at startup.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Narasimhan 2009-06-04 04:20:59 EDT
Thanks for the info. I intend to install F11 final spin once it is out. I will check the sound level and update the result here.
Comment 17 Narasimhan 2009-06-11 22:11:44 EDT
I installed F11 x86_64 live spin on the same hardware. Now the faint sound problem is not there. I checked the front volume slider using alsamixer -c0 and its set to 100%.
Thanks,
Comment 18 Adam Williamson 2009-06-12 12:13:18 EDT
Thanks for confirming the fix!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.