Bug 502305 - keyboard.py error hidden by blank except causes bad handling of Sun keyboards
keyboard.py error hidden by blank except causes bad handling of Sun keyboards
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-23 08:12 EDT by Mads Kiilerich
Modified: 2009-06-01 17:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-01 17:00:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2009-05-23 08:12:42 EDT
Description of problem:

Coding error in /usr/lib/python2.6/site-packages/rhpl/keyboard.py is eaten by blank except clause.

kb = dbus.Interface(bus.get_object("org.freedesktop.Hal", kbs[0], 'org.freedesktop.Hal.Device'))
should be
kb = dbus.Interface(bus.get_object("org.freedesktop.Hal", kbs[0]), 'org.freedesktop.Hal.Device')

The consequence is that Sun keyboards doesn't work as intended.


Version-Release number of selected component (if applicable):

f10 rhpl-0.218-1.i386

I just noticed that the problem is solved in rawhide, so this might be a won't fix for f10 ...
Comment 1 Chris Lumens 2009-06-01 17:00:48 EDT
We generally don't release updates of packages like rhpl since it's so tied in with anaconda and therefore doesn't really benefit from doing updates.  I suppose we could if the problem is serious enough.

Note You need to log in before you can comment on or make changes to this bug.