Bug 502309 - libguestfs build failure - tests occasionally fail with 'ranlib: './libmlguestfs.a': No such file'
libguestfs build failure - tests occasionally fail with 'ranlib: './libmlgues...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libguestfs (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F11VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-23 11:33 EDT by Richard W.M. Jones
Modified: 2009-07-19 06:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.0.58-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-11 13:14:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
build.log (93.21 KB, text/plain)
2009-05-23 11:33 EDT, Richard W.M. Jones
no flags Details
build.log (138.01 KB, text/plain)
2009-06-02 10:39 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2009-05-23 11:33:01 EDT
Created attachment 345198 [details]
build.log

ocamlfind ocamlc -c guestfs.mli
ocamlfind ocamlc -c guestfs.ml
ocamlfind ocamlopt -c guestfs.ml
ocamlmklib -o mlguestfs guestfs_c.o guestfs_c_actions.o guestfs.cmo -L../src/.libs -lguestfs
ocamlmklib -o mlguestfs guestfs_c.o guestfs_c_actions.o guestfs.cmx -L../src/.libs -lguestfs
ranlib: './libmlguestfs.a': No such file

See attached log file for the full build log.

This failure only appears to happen inside Koji, not
on ordinary builds.
Comment 1 Richard W.M. Jones 2009-06-02 10:39:17 EDT
Created attachment 346263 [details]
build.log

Build log from another build failure.
Comment 2 Richard W.M. Jones 2009-06-02 10:48:32 EDT
Just posted about this on caml-list, but after I sent
the message I think I realized what is happening.

I think the problem is we're running parallel make,
and the two invocations of ocamlmklib run in parallel.
This probably causes one to remove or modify the
libmlguestfs.a file created by the other (since
both create the same output file).
Comment 4 Fedora Update System 2009-06-04 07:06:51 EDT
libguestfs-1.0.40-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.40-1.fc11
Comment 5 Fedora Update System 2009-06-04 11:40:01 EDT
libguestfs-1.0.41-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.41-1.fc11
Comment 6 Bug Zapper 2009-06-09 12:26:31 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fedora Update System 2009-06-15 21:32:57 EDT
libguestfs-1.0.40-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-6058
Comment 8 Fedora Update System 2009-06-23 05:15:17 EDT
libguestfs-1.0.51-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.51-1.fc11
Comment 9 Fedora Update System 2009-06-26 22:54:44 EDT
libguestfs-1.0.51-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7011
Comment 10 Fedora Update System 2009-06-29 15:27:55 EDT
libguestfs-1.0.54-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.54-2.fc11
Comment 11 Fedora Update System 2009-07-02 01:54:48 EDT
libguestfs-1.0.54-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libguestfs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-7285
Comment 12 Fedora Update System 2009-07-02 19:26:43 EDT
libguestfs-1.0.55-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.55-1.fc11
Comment 13 Fedora Update System 2009-07-11 05:27:41 EDT
libguestfs-1.0.58-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.58-2.fc11
Comment 14 Fedora Update System 2009-07-11 13:13:03 EDT
libguestfs-1.0.54-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2009-07-19 06:28:21 EDT
libguestfs-1.0.58-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.