Bug 502318 - Runescape claims openjdk won't run its signed applet
Runescape claims openjdk won't run its signed applet
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Rodney Russ
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-23 16:09 EDT by Tom Cross
Modified: 2010-05-27 09:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-27 09:05:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
stderr from firefox with ICEDTEAPLUGIN_DEBUG=true (13.74 KB, text/plain)
2009-06-13 03:19 EDT, Juhani Jaakola
no flags Details
~/.icedteaplugin/java.stderr (21.11 KB, text/plain)
2009-06-14 14:53 EDT, Juhani Jaakola
no flags Details

  None (edit)
Description Tom Cross 2009-05-23 16:09:43 EDT
Description of problem:
Attempting to run Runescape.  Runescape claims it can't run the signed version of the applet.  This worked perfectly in Fedora 10 -- I was able to use the signed applet as well as their 3D mode.

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-20.b14.fc11.x86_64
java-1.6.0-openjdk-plugin-1.6.0.0-20.b14.fc11.x86_64


How reproducible:
Everytime


Steps to Reproduce:
1. Install openjdk-plugin
2. Goto runescape.com via firefox
3. Click on "Free Users click here to play"
4. Runescape.com responds with:  
"  You are seeing this page because we could not start RuneScape on your computer in 'signed' mode. This means that you did not (or were not able to) grant permission to RuneScape to run as it normally does. To avoid seeing this page again, please ensure that you accept the pop-up security warning that appears a few seconds after loading the game. If this pop-up does not appear, try rebooting your machine and make sure you click 'Yes' when asked if you want to trust the RuneScape applet."

Actual results:
runescape works, but in unsigned mode

Expected results:
runescape working in signed mode
Comment 1 Tom Cross 2009-05-24 20:55:20 EDT
Created a new user to make sure it wasn't anything screwed up with my firefox setup.  New user also could not run the signed applet.
Comment 2 Bug Zapper 2009-06-09 12:27:04 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Juhani Jaakola 2009-06-12 15:52:15 EDT
The same problem exists with the following versions:

java-1.6.0-openjdk-plugin-1.6.0.0-22.b16.fc11.i586
java-1.6.0-openjdk-1.6.0.0-22.b16.fc11.i586
Comment 4 Juhani Jaakola 2009-06-12 16:16:40 EDT
When I run firefox in bash, I get this output at the same time that I get the page that says "You are seeing this page because we could not start RuneScape on your computer in 'signed' mode. This means that you did not (or were not able to) grant permission to RuneScape to run as it normally does.":

java.lang.RuntimeException: Failed to handle message: handle 67154749 Thread[Thread-1,5,main]
	at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:440)
	at sun.applet.PluginStreamHandler.handleMessage(PluginStreamHandler.java:295)
	at sun.applet.PluginMessageHandlerWorker.run(PluginMessageHandlerWorker.java:72)
Caused by: java.lang.NullPointerException
	at net.sourceforge.jnlp.NetxPanel.isAlive(NetxPanel.java:147)
	at sun.applet.PluginAppletViewer.<init>(PluginAppletViewer.java:313)
	at sun.applet.PluginAppletViewerFactory.createAppletViewer(PluginAppletViewer.java:121)
	at sun.applet.PluginAppletViewer.parse(PluginAppletViewer.java:1604)
	at sun.applet.PluginAppletViewer$7.run(PluginAppletViewer.java:1528)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.applet.PluginAppletViewer.parse(PluginAppletViewer.java:1537)
	at sun.applet.PluginAppletViewer.handleMessage(PluginAppletViewer.java:414)
	... 2 more
Comment 5 Juhani Jaakola 2009-06-13 02:24:48 EDT
Please ignore my last message with the RuntimeException - I tried to run Runescape on another Fedora 11 machine with the same versions, and I got the signed mode complain page but no errors appeared on the bash window!

How could we debug this?
Comment 6 Juhani Jaakola 2009-06-13 03:19:14 EDT
Created attachment 347717 [details]
stderr from firefox with ICEDTEAPLUGIN_DEBUG=true

I started firefox with the following command and navigated to Runescape until the signed mode complain page appeared. I attached the stderr.

ICEDTEAPLUGIN_DEBUG=true firefox > /tmp/out.txt 2> /tmp/err.txt
Comment 7 Deepak Bhole 2009-06-14 12:14:14 EDT
Thanks for the log. I am not really sure why it is not working on your side. Every time I try to load it, it works for me.

Can you also post the Java logs? They would be quite helpful... to get the java logs, run the same way you did before (with ICEDTEAPLUGIN_DEBUG=true from the terminal) .. the java logs then end up in ~/.icedteaplugin/java.std* files.
Comment 8 Juhani Jaakola 2009-06-14 14:53:59 EDT
Created attachment 347847 [details]
~/.icedteaplugin/java.stderr

Here is the ~/.icedteaplugin/java.stderr

The ~/.icedteaplugin/java.stdout file is empty.
Comment 9 Deepak Bhole 2009-07-10 11:45:29 EDT
When you ran it to get those logs, did it still fail? The logs seem to indicate that it worked and was then closed properly..
Comment 10 Deepak Bhole 2009-07-10 18:43:03 EDT
Hi Juhani. Please ignore Comment #9. I have identified the problem. It will be fixed upstream shortly. Thanks!
Comment 11 Tom Cross 2009-07-11 17:13:00 EDT
Thank you!
Comment 12 Pat 2009-07-25 19:06:20 EDT
Has the patch for this bug been submitted? 

I'm also having this problem and was curious on the status of the fix you mentioned.
Comment 13 Deepak Bhole 2009-07-27 13:08:00 EDT
The patch has been committed upstream. We are working on the Fedora side packages and hope to have it up soon.
Comment 14 Tom Cross 2009-10-23 12:08:51 EDT
Runescape appears to be happy with Fedora 11 + updates now.

Thank you!!
Comment 15 Bug Zapper 2010-04-27 10:29:21 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.