Bug 502322 - qemu not updated on upgrade from F10 to F11
qemu not updated on upgrade from F10 to F11
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-23 18:48 EDT by Gerry Reno
Modified: 2009-06-03 17:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-03 17:43:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg (74.90 KB, text/plain)
2009-05-25 18:04 EDT, Gerry Reno
no flags Details
boot log (4.16 KB, text/plain)
2009-05-25 18:05 EDT, Gerry Reno
no flags Details

  None (edit)
Description Gerry Reno 2009-05-23 18:48:42 EDT
Description of problem:
Upgraded host from F10 to F11 (x86_64) and then x86 qemu guests had major problems.  They either would not run at all or they would run extremely slow.

Version-Release number of selected component (if applicable):
2.6.29.3-155.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. upgrade to F11 (x86_64)
2. start x86 qemu guest
3. see x86 qemu guest fail
  
Actual results:
guest either fails to run or runs extremely slow

Expected results:
guest runs normally

Additional info:

# cat /proc/cpuinfo #showing just first cpu
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 16
model           : 2
model name      : AMD Phenom(tm) 9850 Quad-Core Processor
stepping        : 3
cpu MHz         : 2511.618
cache size      : 512 KB
physical id     : 0
siblings        : 4
core id         : 0
cpu cores       : 4
apicid          : 0
initial apicid  : 0
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nonstop_tsc pni monitor cx16 lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs
bogomips        : 5023.23
TLB size        : 1024 4K pages
clflush size    : 64
cache_alignment : 64
address sizes   : 48 bits physical, 48 bits virtual
power management: ts ttp tm stc 100mhzsteps hwpstate

# rpm -q kernel qemu
kernel-2.6.29.2-126.fc11.x86_64
kernel-2.6.29.3-155.fc11.x86_64
qemu-0.10-16.fc11.x86_64


If I make each guest only use 1 cpu then I can get them all to run but they run very slow.

If I boot into the 2.6.29.2-126 kernel things are even worse.  Then only 1 guest will run at all.
Comment 1 Gerry Reno 2009-05-23 18:52:32 EDT
Guest emulators are:  /usr/bin/qemu-kvm
Comment 2 Gerry Reno 2009-05-23 19:02:45 EDT
Host clocksource:
  kernel line: empty (default)
  Current: tsc
  Available: tsc hpet acpi_pm jiffies

Guest clocksource:
  kernel line: pit
  Current: acpi_pm
  Available: tsc, acpi_pm, jiffies

I tried changing clocksource in the guest to both acpi_pm and jiffies but it didn't help.
Comment 3 Chuck Ebbert 2009-05-25 16:43:51 EDT
Can you attach boot messages from the guest when running on the old and new host kernels?
Comment 4 Gerry Reno 2009-05-25 18:03:47 EDT
The problem is that the F11 kernel is not loading the kvm modules.  Once I loaded them with modprobe then the guests ran normally.

The old kernel is no longer on the machine.  Only the two F11 kernels are there.

I'm attaching dmesg and boot log.
Comment 5 Gerry Reno 2009-05-25 18:04:54 EDT
Created attachment 345361 [details]
dmesg
Comment 6 Gerry Reno 2009-05-25 18:05:37 EDT
Created attachment 345362 [details]
boot log
Comment 7 Gerry Reno 2009-05-25 18:59:58 EDT
Ok, I thought I had this problem fixed but after rebooting the host machine a number of times the kvm modules fail to load and the guests go back to extremely slow performance because there is no kvm.
Comment 8 Chuck Ebbert 2009-05-26 11:49:26 EDT
(In reply to comment #7)
> Ok, I thought I had this problem fixed but after rebooting the host machine a
> number of times the kvm modules fail to load and the guests go back to
> extremely slow performance because there is no kvm.  

But can you still load the kvm drivers manually?
Comment 9 Gerry Reno 2009-05-26 11:55:34 EDT
Yes the kvm modules can be loaded manually after each reboot.
Comment 10 Gerry Reno 2009-05-26 12:10:14 EDT
Ok, I found a 'qemu' update and ran 'yum update qemu'.  This added this file: /etc/sysconfig/modules/kvm.modules.  And now the kvm modules stay loaded across reboot.
Comment 11 Chuck Ebbert 2009-05-27 10:33:49 EDT
qemu should have been updated with the upgrade.
Comment 12 Mark McLoughlin 2009-06-03 12:59:48 EDT
Hmm, qemu was updated to qemu-0.10-16.fc11.x86_64, but it sounds like the kvm.modules script was missing/broken ?

Looking at:

  http://kojipkgs.fedoraproject.org/packages/qemu/0.10/16.fc11/x86_64/qemu-system-x86-0.10-16.fc11.x86_64.rpm

kvm.modules looks just fine

Any yum/anaconda logfiles remaining from the upgrade which might shed a light on what happened?
Comment 13 Gerry Reno 2009-06-03 13:49:33 EDT
No logs, but I do remember there were some selinux avc denials I noticed right after it finished.  Don't know how that might affect things.
Comment 14 Mark McLoughlin 2009-06-03 17:43:16 EDT
okay, thanks Gerry

Closing for now - if we get any more reports of this, we should re-open and take a closer look.

Note You need to log in before you can comment on or make changes to this bug.