This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 502333 - virt-manager should show guest disk size in Details
virt-manager should show guest disk size in Details
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-05-23 22:04 EDT by Jens Petersen
Modified: 2010-06-16 13:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: virt-manager-0.8.4-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-16 13:52:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2009-05-23 22:04:43 EDT
Description of problem:
virt-manager should show the size of disk images in the Details of a guest

Steps to Reproduce:
1. Open guest -> Details -> Disk hda
  
Actual results:
No size shown

Expected results:
Disk storage size to be shown.

Additional info:
Have to go to /var/lib/libvirt/images to check size.
Comment 1 Mark McLoughlin 2009-05-25 11:55:04 EDT
Makes sense

(For future reference, this is virt-manager-0.7.0)
Comment 2 Chris Lalancette 2009-05-26 02:36:19 EDT
I took a quick look at this yesterday, and unfortunately, there's a reason that we don't show that type of detail.  Currently, the only way to get fine details about a particular file, partition, or LVM volume is to have it as a libvirt volume.  To have a libvirt volume, you need to have a libvirt storage pool.

Now, we do have a libvirt storage pool by default for /var/lib/libvirt/images, so getting storage data about any files in there is relatively easy.  The problem becomes when you think about getting the data of arbitrary files or partitions.  If, for instance, the user is storing their files in /storage, and their guest disk is in /storage/vm.dsk, in order to get information about /storage/vm.dsk we would first need to create a storage pool for /storage, and then get the data.  This could get out of hand quickly, since in theory, we would need to create a storage pool for every directory in the system.  This needs to be thought about more; maybe it's OK in practice, since most people will be using just one or two directories to store their images.

Chris Lalancette
Comment 3 Cole Robinson 2009-05-26 10:15:11 EDT
Yeah, I'm not comfortable with auto pool-ifying all storage. But if the storage is already managed, we should be pulling info from libvirt and displaying it in VM->Details->Disk, info like capacity, allocation, file format, backing store, etc.
Comment 4 Jens Petersen 2009-05-28 20:50:39 EDT
Ok - even just showing the size of physical disk files would be useful IMHO if more info is not available.
Comment 5 Cole Robinson 2010-03-03 18:54:33 EST
Okay, updated disk details to show disk size if available:

http://hg.fedorahosted.org/hg/virt-manager/rev/78c31a870744
Comment 6 Bug Zapper 2010-03-15 08:38:12 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Fedora Update System 2010-05-27 16:59:52 EDT
virt-manager-0.8.4-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/virt-manager-0.8.4-1.fc13
Comment 8 Fedora Update System 2010-05-28 14:09:04 EDT
virt-manager-0.8.4-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/virt-manager-0.8.4-1.fc13
Comment 9 Fedora Update System 2010-06-16 13:51:26 EDT
virt-manager-0.8.4-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.