Bug 502335 - Automount schema not compatible with Mac OS X Leopard
Automount schema not compatible with Mac OS X Leopard
Status: CLOSED WONTFIX
Product: 389
Classification: Community
Component: Schema (Show other bugs)
1.2.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Rich Megginson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-24 00:15 EDT by W. Michael Petullo
Modified: 2015-11-13 20:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-13 20:28:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2009-05-24 00:15:03 EDT
Description of problem:
I am interested in serving automount maps using LDAP. The schema, 60autofs.ldif, that fedora-ds-base provides is not compatible with Mac OS X Leopard.

Version-Release number of selected component (if applicable):
fedora-ds-base-1.2.0-4.fc10.i386

How reproducible:
Every time

Steps to Reproduce:
Notice that the Mac OS X automount schema is slightly different that the one that fedora-ds-base installs. I have replaced the fedora-ds-base schema with one that supports Mac OS X.
  
Actual results:


Expected results:


Additional info:
Because the schema Fedora's automounter expects is configurable (/etc/sysconfig/autofs), it seems that the schema convention used by Mac OS X could be the default.
Comment 1 W. Michael Petullo 2009-05-24 00:20:18 EDT
The following schema supports Mac OS X (contains slight changes from the fedora-ds-base schema):

# 60autofs.ldif - From draft-howard-rfc2307bis
################################################################################
#
dn: cn=schema
#
################################################################################
#
attributeTypes: (
  1.3.6.1.1.1.1.31 
  NAME 'automountMapName'
  DESC 'automount Map Name'
  EQUALITY caseExactMatch
  SYNTAX 1.3.6.1.4.1.1466.115.121.1.15
  SINGLE-VALUE
  )
#
################################################################################
#
attributeTypes: (
  1.3.6.1.1.1.1.32
  NAME 'automountKey'
  DESC 'Automount Key value'
  EQUALITY caseExactMatch
  SYNTAX 1.3.6.1.4.1.1466.115.121.1.15
  SINGLE-VALUE
  )
#
################################################################################
#
attributeTypes: (
  1.3.6.1.1.1.1.33
  NAME 'automountInformation'
  DESC 'Automount information'
  EQUALITY caseExactMatch
  SYNTAX 1.3.6.1.4.1.1466.115.121.1.15
  SINGLE-VALUE
  )
#
################################################################################
#
objectClasses: (
  1.3.6.1.1.1.2.16
  NAME 'automountMap'
  SUP top
  STRUCTURAL
  MUST ( automountMapName )
  MAY description
  )
#
################################################################################
#
objectClasses: (
  1.3.6.1.1.1.2.17
  NAME 'automount'
  SUP top
  STRUCTURAL
  DESC 'Automount'
  MUST ( automountKey $ automountInformation )
  MAY description
  )
#
################################################################################
#
Comment 2 Martin Kosek 2012-01-04 08:42:20 EST
Upstream ticket:
https://fedorahosted.org/389/ticket/103
Comment 4 Noriko Hosoi 2015-11-13 20:28:15 EST
Closing this bug due to moving to the trac system.

https://fedorahosted.org/389/ticket/103

Note You need to log in before you can comment on or make changes to this bug.