Bug 502361 - ejabberd init scripts fail to start ejabberd properly
Summary: ejabberd init scripts fail to start ejabberd properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ejabberd
Version: 10
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-05-24 12:59 UTC by Benjamin Kwiecień
Modified: 2009-09-10 22:56 UTC (History)
2 users (show)

Fixed In Version: 2.0.5-6.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-06 20:41:04 UTC
Type: ---


Attachments (Terms of Use)

Description Benjamin Kwiecień 2009-05-24 12:59:53 UTC
Description of problem:

When configuring ejabberd, I am able to start the server manually by using the ejabberdctl script, which loads the node ejabberd@localhost.  This appears to agree with the installed package(s).  However, when I load ejabberd using the init script, the server fails to load--erlang loads but the process fails somewhere during loading, although the affected processes don't die (I have to kill them manually)  The server returns an error to the effect that it wasn't properly evoked; what I can see is that instead of the node being ejabberd@localhost as usual, the error reports ejabberd@myhost where "myhost" is the hostname I chose for my system when I first installed Fedora (the hostname was set by the installer).  If I manually change my hostname to "localhost" then the init script work, but that is not an acceptable solution.  Looking at the init script, I noticed it uses a very funny/nonstandard method of invoking ejabberd (not ejabberdctl), from which I believe the error stems.  The status/stop scripts all use ejabberdctl, but the start script seems to be invoking evoking erlang directly and specifying, redundantly and possibly incorrectly, runtime paramaters that ejabberdctl takes care of on its own.

Version-Release number of selected component (if applicable): 2.0.5-3.fc10


How reproducible:


Steps to Reproduce:
1. Specify a hostname and domain other than localhost.localdomain in the Fedora installer
2. Install ejabberd (the default config file should be adequate just to load the server)
3. Attempt to start ejabberd using the init script
  
Actual results:

ejabberd doesn't start.  erlang loads and the process hangs, so the server never loads.

Expected results:

ejabberd should start correctly.

Additional info:

Comment 1 Peter Lemenkov 2009-05-24 13:47:31 UTC
(In reply to comment #0)
> Description of problem:

> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. Specify a hostname and domain other than localhost.localdomain in the Fedora
> installer
> 2. Install ejabberd (the default config file should be adequate just to load
> the server)
> 3. Attempt to start ejabberd using the init script

Cannot reproduce - I'm able to start ejabberd from init-script and stop it using ejabberdctl and vise versa. And my domainname (hostname -s) is not a simple localhost.

However, the idea, to rely in init-script on ejabberdctl completely, sounds interesting - at least we'll clean up things a little. I'll try to remove all direct erlang invocations in init-script.

Comment 2 Fedora Update System 2009-08-25 20:14:22 UTC
ejabberd-2.0.5-6.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/ejabberd-2.0.5-6.el5

Comment 3 Fedora Update System 2009-08-25 20:14:27 UTC
ejabberd-2.0.5-6.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/ejabberd-2.0.5-6.fc10

Comment 4 Fedora Update System 2009-08-25 20:14:31 UTC
ejabberd-2.0.5-6.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/ejabberd-2.0.5-6.fc11

Comment 5 Fedora Update System 2009-08-26 23:34:28 UTC
ejabberd-2.0.5-6.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ejabberd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0351

Comment 6 Fedora Update System 2009-08-27 02:10:09 UTC
ejabberd-2.0.5-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ejabberd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9021

Comment 7 Fedora Update System 2009-08-27 02:17:33 UTC
ejabberd-2.0.5-6.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ejabberd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9037

Comment 8 Fedora Update System 2009-09-06 20:40:59 UTC
ejabberd-2.0.5-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2009-09-06 20:41:45 UTC
ejabberd-2.0.5-6.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2009-09-10 22:56:53 UTC
ejabberd-2.0.5-6.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.