Bug 502362 - kdm does not register the close of TTY sessions
kdm does not register the close of TTY sessions
Status: CLOSED DUPLICATE of bug 470004
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-24 09:06 EDT by Tim Landscheidt
Modified: 2009-05-24 10:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-24 10:39:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Landscheidt 2009-05-24 09:06:22 EDT
Description of problem:

When I have logged in on TTY shells ([Ctrl-Alt-F2] & Co.) and exited normally (via exit), the KDM asks if I want to abort the active sessions.

  I file this bug against kdebase as no kdm component is available, but of course the true cause may be in another service (cf. Additional Information). Please reassign as appropriate.


Version-Release number of selected component (if applicable):

kdm-4.2.3-4.fc10.i386


How reproducible:

Always.


Steps to Reproduce:

1. Start computer.
2. Wait for KDM screen.
3. Press [Ctrl-Alt-F2] to switch to TTY.
4. Login (as user or root).
5. Logout ("exit" or [Ctrl-D]).
6. Press [Alt-F1] to switch to KDM screen.
7. Choose reboot or shutdown from menu.


Actual results:

| Restart [Turn Off] Computer

| Abort active sessions:

| Session          Location
| tim: TTY login   vt2

| OK               Cancel


Expected results:

The system should reboot/shutdown without prompting as the session is closed.


Additional info:

/var/log/secure contains the lines:

| May 24 11:13:47 lockfix kdm: :0[2091]: PAM unable to dlopen(/lib/security/pam_gnome_keyring.so): /lib/security/pam_gnome_keyring.so: cannot open shared object file: No such file or directory
| May 24 11:13:47 lockfix kdm: :0[2091]: PAM adding faulty module: /lib/security/pam_gnome_keyring.so

for every system start. I do not know how they come into play.

  Sometimes, after pressing [OK], only a blank screen occurs (text mode with cursor blinking). Logging in on a TTY shows that a kdm_greet process is running. HUPping it is sufficient to start the real reboot/shutdown. As this behaviour is random, I cannot reproduce it reliably.
Comment 1 Rex Dieter 2009-05-24 10:39:56 EDT
upstart bug #470004

*** This bug has been marked as a duplicate of bug 470004 ***

Note You need to log in before you can comment on or make changes to this bug.