Bug 502391 - unhandled exception if anaconda can't create required install partitions
unhandled exception if anaconda can't create required install partitions
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2009-05-24 13:09 EDT by cornel panceac
Modified: 2009-05-26 13:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-05-26 13:34:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description cornel panceac 2009-05-24 13:09:34 EDT
Description of problem:

tried to install f11 preview (from i686 gnome live cd) on a friends notebook wich have 100 GB free space in the middle of hard disk. on that hard disk was already installed windows (xp and vista). windows used three partitions. trying to install, f11 preview entered unhandled exception (and failed to send info to bugzilla due to the card being wireless not connected yet to shared-key protected wireless network, but that's another story :)).

then i've tried f10dvd wich didn't crashed but complained it can not create more than one partition on existing free space. then i've noticed that windows (aparently vista) assigned the last partition to a logical drive inside an extended partition wich has exactly one drive and no free space. hence, on the partition table was room left for just another primary partition, not enough for a typical linux install, wich requires at least / and swap.

Version-Release number of selected component (if applicable):
f11preview i686 gnome live cd

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

i believe the normal behaviour would have been to just say: :"can't create another partition because the partition table is already full and no space in extended partition"

Additional info:
Comment 1 Chris Lumens 2009-05-25 18:34:25 EDT
Please attach the complete traceback to this bug report.  These can be hard to track down without that information and knowing what was on the disk to begin with.
Comment 2 cornel panceac 2009-05-26 00:12:14 EDT
the workaround was to replace (backup,etc) the logical partition with a primary partition and create extended parition on the free space. so what i wanna do is put a test hard disk into the test computer, create a partition layout similar to the one above, and get the exception again. the plan is to do this 12hours from now ( because i have to go to work now :) ). i'll report back after.

Comment 3 cornel panceac 2009-05-26 10:39:55 EDT
unfortunately i'm unable to get the error on my test system if i use the preview cd. the test disk has a size of 20GB. the machine where i get the exception had a 300 GB pata hard disk partitioned like this"

first, a ~ 50 GB partition. then a ~ 100 GB free space , then another ~ 50 GB partition, then ~ 100 GB extended partition and inside all space was used by one logical partition. all partition types were 7. all partitions were formatted and contained data.

 itried different sizes for the partition and for the free space (including partitions of 2 cyl size) but everytime anaconda reported "there's no enough disk space". 

so unless someone else gets the exception and manage to provide more info, i consider this bug closed.

as a side note, if i let anaconda use the default "replace existing linux system", it replaced the first partition (from cyl 1 to 2, formatted ntfs) and created a logvol for the other partitions.

as another side note, at the screen where the user is warned this is not a production release, if i choose exit, it either wanted to reboot (wich is not right on a live cd) or cancel. cancel returns to the warning screen.

i will try still the 22.05 boot.iso

thank you for your assistance.
Comment 4 Chris Lumens 2009-05-26 13:34:57 EDT
If you are able to reproduce the original problem and can attach a traceback, please feel free to reopen this bug report.  We have a fairly large number of storage partitioning bugs so it's likely we do already have your bug in here somewhere, but unfortunately I can't tell you which off the top of my head.
Comment 5 cornel panceac 2009-05-26 13:45:31 EDT
ok, thnx again.

Note You need to log in before you can comment on or make changes to this bug.