Bug 502399 - gpk-application doesn't like yum-plugin-remove-with-leaves
gpk-application doesn't like yum-plugin-remove-with-leaves
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 503370 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-24 16:31 EDT by Matěj Cepl
Modified: 2009-06-18 07:59 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.4.8-1.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 05:34:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2009-05-24 16:31:01 EDT
Description of problem:

When I have installed yum-plugin-remove-with-leaves plugin for yum, and tried to install (not remove) a pakcage, I got this backtrace:

Traceback (most recent call last):
  File "/usr/share/PackageKit/helpers/yum/yumBackend.py", line 1215, in _get_depends_not_installed
    rc, msgs =  self.yumbase.buildTransaction()
  File "/usr/lib/python2.6/site-packages/yum/__init__.py", line 719, in buildTransaction
    self.plugins.run('postresolve', rescode=rescode, restring=restring)
  File "/usr/lib/python2.6/site-packages/yum/plugins.py", line 179, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/remove-with-leaves.py", line 71, in postresolve_hook
    if opts.remove_leaves or remove_always:
AttributeError: 'NoneType' object has no attribute 'remove_leaves'


Version-Release number of selected component (if applicable):
yum-plugin-remove-with-leaves.noarch 0:1.1.21-2.fc11 
gnome-packagekit-2.27.2-0.2.20090414git.fc11.x86_64

How reproducible:
happened once

Steps to Reproduce:
1.see above
2.
3.
Comment 1 Richard Hughes 2009-05-26 05:34:50 EDT
ommit f3834b8d932aa52468e9b606472ca9d19f010145
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue May 26 10:33:52 2009 +0100

    yum: Blacklist remove-with-leaves as well. Fixes rh#502399
Comment 2 Fedora Update System 2009-06-01 06:55:01 EDT
PackageKit-0.4.8-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/PackageKit-0.4.8-1.fc11
Comment 3 Richard Hughes 2009-06-01 07:43:37 EDT
*** Bug 503370 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2009-06-07 05:04:59 EDT
kpackagekit-0.4.1-3.fc11,PackageKit-0.4.8-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/kpackagekit-0.4.1-3.fc11,PackageKit-0.4.8-1.fc11
Comment 5 Fedora Update System 2009-06-18 07:59:16 EDT
PackageKit-0.4.8-1.fc11, kpackagekit-0.4.1.1-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.