Bug 502410 - F11 X: typing Ctrl-<arrow keys> can cause cursor to zoom off screen in direction of arrow key
F11 X: typing Ctrl-<arrow keys> can cause cursor to zoom off screen in direct...
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev (Show other bugs)
All Linux
low Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
: 504241 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2009-05-24 21:43 EDT by Gerry Reno
Modified: 2018-04-11 03:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2010-06-28 08:41:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg.conf (999 bytes, text/plain)
2009-05-25 19:47 EDT, Gerry Reno
no flags Details
Xorg.0.log (97.77 KB, text/plain)
2009-05-25 19:48 EDT, Gerry Reno
no flags Details
dmesg (120.51 KB, text/plain)
2009-05-25 19:49 EDT, Gerry Reno
no flags Details

  None (edit)
Description Gerry Reno 2009-05-24 21:43:21 EDT
Description of problem:
When editing commands on command line or documents in terminal windows I have experienced loss of mouse control sometimes when type the combo Ctrl-<any arrow key>.  This will cause the mouse cursor to zoom off the screen in the direction of the arrow key and stay off the screen.  If you try to bring the cursor back it will continue to try to move off the screen in the direction of the arrow key.

Version-Release number of selected component (if applicable):

How reproducible:
I haven't found a sure-fire way of reproducing this yet.

Steps to Reproduce:
1. edit commands, edit documents, type control sequence Ctrl-<arrow key> to move around.
Actual results:
cursor will sometimes zoom off screen.

Expected results:
cursor behaves normally

Additional info:
This has happened in beta and preview and the latest rawhide.
Comment 1 Matěj Cepl 2009-05-25 18:55:22 EDT
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf, if available), /var/log/dmesg, and X server log file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file attachments using the bugzilla file attachment link below.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Gerry Reno 2009-05-25 19:47:10 EDT
Created attachment 345369 [details]
Comment 3 Gerry Reno 2009-05-25 19:48:42 EDT
Created attachment 345370 [details]
Comment 4 Gerry Reno 2009-05-25 19:49:41 EDT
Created attachment 345371 [details]
Comment 5 Bug Zapper 2009-06-09 12:30:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
Comment 6 Matěj Cepl 2009-11-05 13:29:48 EST
Since this bugzilla report was filed, there have been several major updates in various components of the Xorg system, which may have resolved this issue. Users who have experienced this problem are encouraged to upgrade their system to the latest version of their packages. For packages from updates-testing repository you can use command

yum upgrade --enablerepo='*-updates-testing'

Alternatively, you can also try to test whether this bug is reproducible with the upcoming Fedora 12 distribution by downloading LiveMedia of F12 Beta available at http://alt.fedoraproject.org/pub/alt/nightly-composes/ . By using that you get all the latest packages without need to install anything on your computer. For more information on using LiveMedia take a look at https://fedoraproject.org/wiki/FedoraLiveCD .

Please, if you experience this problem on the up-to-date system, let us now in the comment for this bug, or whether the upgraded system works for you.

If you won't be able to reply in one month, I will have to close this bug as INSUFFICIENT_DATA. Thank you.

[This is a bulk message for all open Fedora Rawhide Xorg-related bugs. I'm adding myself to the CC list for each bug, so I'll see any comments you make after this and do my best to make sure every issue gets proper attention.]
Comment 7 Gerry Reno 2009-11-06 11:35:57 EST
I just tried this in F12beta and the problem is still there.  This is happening mainly when using a KVM in a server rack.  It seems that at times the KVM may be delivering a combination key-stroke such as Ctrl-<left arrow> or Alt-<left arrow> or Shift-<left arrow> instead of just a single <left arrow> keystroke.  KVM's do these types of things every once in a while.  Sometimes they will shift case on you.  If you've worked with KVM's you'll know what I mean.  Anyway, this happens in gnome-terminal windows.  The result is the same as before, in that the GUI cursor runs off the screen in the direction of the arrow-key that was pressed.  It would be good if we could find what keystroke combination is responsible for this behavior and then filter that combination out.  I have not been able to reproduce it with any combination keystroke that I can find.  Hopefully this info will help track this down.  It's been a real pain to deal with.  The only recovery is to restart X.
Comment 8 Chris Campbell 2009-11-13 12:45:47 EST
*** Bug 504241 has been marked as a duplicate of this bug. ***
Comment 9 Peter Hutterer 2009-11-24 01:36:08 EST
the only combo that should cause the cursor to move is Shift+Numlock to switch mousekeys on and then any of the cursor keys on the numlock. nothing with Ctrl though.

for clarification - are we talking about the text cursor (the I-beam) or the graphical cursor controlled by the mouse?
Comment 10 Gerry Reno 2009-11-24 11:15:16 EST
Graphical (arrow) cursor.
Comment 11 Bug Zapper 2010-04-27 10:30:19 EDT
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 12 Bug Zapper 2010-06-28 08:41:52 EDT
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.