Bug 502418 - Update xsl to support glossary.sort - rebase to 1.73
Update xsl to support glossary.sort - rebase to 1.73
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: docbook-style-xsl (Show other bugs)
5.3
All Linux
medium Severity medium
: rc
: 5.4
Assigned To: Ondrej Vasik
BaseOS QE
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-24 23:13 EDT by David O'Brien
Modified: 2011-08-25 05:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-25 05:36:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David O'Brien 2009-05-24 23:13:11 EDT
Description of problem:

Currently the use of Glossaries in docbook (as supported by publican and rhel tool-chain) is problematic because it doesn't allow for correct sorting in LOTE. Providing support for glossary.sort will hopefully fix this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a glossary in a book
2. Translate the glossary
3. Rebuild the book 
  
Actual results:
afaik the original English sorting is retained. To date we've been asked not to use glossaries at all, and I don't have a translated one to verify results.

Expected results:
The glossary should be sorted by the target language entries, not the English entries.

Additional info:
The following was provided as a reference:

http://www.sagehill.net/docbookxsl/GlossarySort.html
Comment 1 Ondrej Vasik 2009-05-25 03:48:27 EDT
Glossary support was added in 1.73 stylesheets, so it would mean rebase of the xsl stylesheets package. It should be not a big problem as the xsl stylesheets almost 100% backward compatible.
Comment 5 RHEL Product and Program Management 2009-11-06 13:50:04 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 RHEL Product and Program Management 2010-08-09 14:38:37 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 9 RHEL Product and Program Management 2011-01-11 16:05:05 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-01-11 17:30:27 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 11 RHEL Product and Program Management 2011-05-31 09:42:13 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 Ondrej Vasik 2011-08-25 05:36:16 EDT
Closing WONTFIX, too late in release cycle for this and glosary suppoprt is in RHEL-6 version of docbook-style-xsl

Note You need to log in before you can comment on or make changes to this bug.