Bug 502445 - Sys::Syslog can not deal with EMERG level messages
Sys::Syslog can not deal with EMERG level messages
Status: CLOSED DUPLICATE of bug 454602
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: perl (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Marcela Mašláňová
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 06:38 EDT by Lubomir Rintel
Modified: 2009-05-25 09:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 09:58:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Be able to handle EMERG/LOG_EMERG correctly (396 bytes, text/plain)
2009-05-25 06:38 EDT, Lubomir Rintel
no flags Details
Revised patch, allows LOG_KERN which clashes with EMERG (2.91 KB, text/plain)
2009-05-25 07:25 EDT, Lubomir Rintel
no flags Details

  None (edit)
Description Lubomir Rintel 2009-05-25 06:38:21 EDT
Created attachment 345299 [details]
Be able to handle EMERG/LOG_EMERG correctly

Version-Release number of selected component (if applicable):

perl-5.8.8-15.el5_2.1
  
Actual results:

[root@trunk:~] perl -MSys::Syslog -e 'syslog LOG_EMERG => "boo"'
syslog: invalid level/facility: LOG_EMERG at -e line 1

Expected results:

09/05/25 12:25:09 role=?, status=?
[root@trunk:~] perl -MSys::Syslog -e 'syslog LOG_EMERG => "boo"'

Message from syslogd@trunk at May 25 12:25:16 ...
 root: boo

Additional info:

Patch is attached. Fixed upstream. Upstream's new version of the module has the method almost completely rewritten, a similar conditional (permitting log level with numerical value 0) can be spotted there though.
Comment 1 Lubomir Rintel 2009-05-25 07:25:41 EDT
Created attachment 345302 [details]
Revised patch, allows LOG_KERN which clashes with EMERG
Comment 2 Marcela Mašláňová 2009-05-25 09:58:52 EDT
This was already fixed in #454602. This update should be in RHEL-5.3 update.

*** This bug has been marked as a duplicate of bug 454602 ***

Note You need to log in before you can comment on or make changes to this bug.