Bug 502503 - g-v-c-applet doesn't recover from a dead pa server
g-v-c-applet doesn't recover from a dead pa server
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 10:39 EDT by David Timms
Modified: 2009-05-25 13:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-25 13:17:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 564311 None None None Never

  None (edit)
Description David Timms 2009-05-25 10:39:23 EDT
Description of problem:
Should pulseaudio go away, gvc applet shows a lost connection, OK dialog. After this the applet does not seem to refresh the connection, nor provide a way for the user to do so, leaving them with no volume-control, muting, output selection, until they logout/reboot.

Version-Release number of selected component (if applicable):
gnome-media-2.26.0-6.fc11.i586

How reproducible:
easy.

Steps to Reproduce: (easiest way I could find).
1. pulseaudio -k
2. pulseaudio -vvvv
3. click any control in the popup or audio preferences dialog.
  
Actual results:
1. a dialog is shown mentioning something lost connection; it isn't that obvious to what this dialog appeared from or why.
3. elements move, but no audio changes occur.

Expected results:
applet continues to control audio when it's elements are adjusted.

Additional info:
-applet should at least disable all controls (since operating them cannot achieve anything)
-applet could provide a popup item: "reconnect to pulseaudio", that becomes available when applet noticed the connection go away, and disable it again once it is connected.
- ~"no command line workarounds please", even though they work. kill, restart applet.

and maybe:
- more info in the lost connection dialog eg. "the connection to the pulseaudio sound server was lost. The sound server is no longer running, and may need to be restarted", would you like to try restarting now ? yes"
-applet could attempt to connect every 2 seconds, until successful ?
Comment 1 Bastien Nocera 2009-05-25 13:17:49 EDT
This is a known upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=564311

File a bug against PulseAudio if you have particular bugs you want investigated in PulseAudio itself.

Note You need to log in before you can comment on or make changes to this bug.