Bug 502529 - SELinux fails to load the GUI
SELinux fails to load the GUI
Status: CLOSED DUPLICATE of bug 502557
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-25 17:33 EDT by pagina_secunda
Modified: 2009-05-26 08:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 08:55:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pagina_secunda 2009-05-25 17:33:38 EDT
Description of problem: selinux will not open in a GUI either through the menu or through the terminal.

Version-Release number of selected component (if applicable): I have no idea, except that I keep my computer up to date

How reproducible: Very reproducible, fails the same way each time for me.


Steps to Reproduce:
1. Open terminal
2. Establish yourself as root with "su"
3. Type in system-config-selinux

-or-

1.Click on the system menu
2.Click on Administration
3.Click on SELinux Management
  
Actual results:
1. Using the menu to access it: none
2. Using the terminal to access it:
"system-config-selinux
/usr/share/system-config-selinux/system-config-selinux.py:72: Warning: IA__g_object_get_valist: object class `GnomeProgram' has no property named `default-icon'
  xml = gtk.glade.XML ("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 188, in <module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 91, in __init__
    self.add_page(portsPage.portsPage(xml))
  File "/usr/share/system-config-selinux/portsPage.py", line 69, in __init__
    self.load()
  File "/usr/share/system-config-selinux/portsPage.py", line 136, in load
    self.store.set_value(iter, PROTOCOL_COL, k[2])
IndexError: tuple index out of range"

and exit

Expected results: Open the SELinux Management GUI window


Additional info:
Comment 1 Daniel Walsh 2009-05-26 08:55:43 EDT

*** This bug has been marked as a duplicate of bug 502557 ***

Note You need to log in before you can comment on or make changes to this bug.