Bug 50256 - IPv6 enabling
Summary: IPv6 enabling
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: wget   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-29 09:45 UTC by Pekka Savola
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-11 11:21:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
additional patch required (778 bytes, patch)
2001-07-29 09:46 UTC, Pekka Savola
no flags Details | Diff
ipv4-only compilation fix (1.12 KB, patch)
2001-08-11 11:19 UTC, Pekka Savola
no flags Details | Diff

Description Pekka Savola 2001-07-29 09:45:51 UTC
I don't see this as critical as there are other tools (e.g. lynx/ncftp) to accomplish the same, but
in any case...

wget-1.7 has been patched (based on ftp://ftp.kame.net/pub/kame/misc/wget-17*) to enable
ipv6.

The updated package is at http://www.netcore.fi/pekkas/linux/ipv6/ 

Basically:
 - KAME patch
 - additional patch to configure.in, config.h.in to make the autoconf work
 - add autoconf, %configure --enable-ipv6 (else it will go on only if ipv6 is enabled on _building_ host)

IPv6-binary tested to work on IPv4-only systems, connecting to both EPRT/PORT ftp sites with ipv4, etc.

Comment 1 Pekka Savola 2001-07-29 09:46:38 UTC
Created attachment 25292 [details]
additional patch required

Comment 2 Trond Eivind Glomsrxd 2001-07-30 03:31:25 UTC
Requiring IPv6 on the build machine is not acceptable.

Comment 3 Pekka Savola 2001-07-30 06:10:29 UTC
Let me clarify.

With the patch if you do: 

%configure, IPv6 will get enabled only if the building host has ipv6 enabled

%configure --enable-ipv6 (as suggested), IPv6 will always get enabled, and the
building host doesn't have to be IPv6-enabled.

Sorry for too few words :-)


Comment 4 Trond Eivind Glomsrxd 2001-07-30 19:07:58 UTC
Is that really the only patch? It looks short...

Comment 5 Pekka Savola 2001-07-30 19:20:27 UTC
No; this is just an additonal patch, required to make autoconf'ized IPv6-enabling to work
(there were bugs in KAME patch).

The main patch is at ftp://ftp.kame.net/pub/kame/misc/wget-17*, or a tailed-down version 
(patches to configure, libtool etc. removed) in my .src.rpm.

Comment 6 Trond Eivind Glomsrxd 2001-08-09 19:14:06 UTC
-2 from your site doesn't build properly:

gcc -I. -I.    -DHAVE_CONFIG_H -DSYSTEM_WGETRC=\"/etc/wgetrc\"
-DLOCALEDIR=\"/usr/share/locale\" -O2 -march=i386 -mcpu=i686 -c host.c
host.c: In function `store_hostaddress':
host.c:209: structure has no member named `sa_len'


Comment 7 Trond Eivind Glomsrxd 2001-08-09 19:15:33 UTC
It does build with --enable-ipv6, but needs to build without it as well.

Comment 8 Pekka Savola 2001-08-11 11:19:39 UTC
Created attachment 27393 [details]
ipv4-only compilation fix

Comment 9 Pekka Savola 2001-08-11 11:21:14 UTC
Sigh..  there's a dummy sa_len that isn't used anywhere at least yet.  sa_len was removed in glibc 2.2.

Attached patch will fix it.  Also updated in my src.rpm.

Comment 10 Pekka Savola 2001-11-06 20:51:44 UTC
Mmm.  I really don't get why WONTFIX?


Comment 11 Trond Eivind Glomsrxd 2001-11-06 21:02:59 UTC
Mainly because I'd like someone to push it into the upstream version :)

Comment 12 Pekka Savola 2001-11-06 21:12:49 UTC
Sigh.


Note You need to log in before you can comment on or make changes to this bug.