This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 502594 - phpMyAdmin does not work by default
phpMyAdmin does not work by default
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: phpMyAdmin (Show other bugs)
11
i386 Linux
low Severity high
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 07:50 EDT by markm
Modified: 2009-06-14 13:46 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-14 13:46:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description markm 2009-05-26 07:50:23 EDT
Description of problem:

When users install phpMyAdmin on their machines, they expect phpMyAdmin to work out of the box.

Version-Release number of selected component (if applicable):

phpMyAdmin-3.1.5-1.fc11.noarch

How reproducible:

always

Steps to Reproduce:
1. install phpMyAdmin
2. type http://localhost/phpMyAdmin/
3. type username 'root' with no password
  
Actual results:

phpMyAdmin repeats question

Expected results:

phpMyAdmin to show databases
Comment 1 markm 2009-05-26 07:51:28 EDT
actually, above link does not work, it gives:

Forbidden

You don't have permission to access /phpMyAdmin/ on this server.
Apache/2.2.11 (Fedora) Server at localhost Port 80


you need to type http://127.0.0.1/phpMyAdmin/ in order to see phpMyAdmin.
Comment 2 Robert Scheck 2009-05-26 08:12:23 EDT
Marek, thanks for your report. I'm the co-maintainer of phpMyAdmin in Fedora.

If http://127.0.0.1/phpMyAdmin/ works and http://localhost/phpMyAdmin/ doesn't
work, this is an Apache configuration thing, which phpMyAdmin configuration can
not trigger.

When re-trying your scenario with "yum install httpd phpMyAdmin -y; /etc/init.d
/httpd restart" and trying to access it, it works as expected - login dialog of
phpMyAdmin appears.

If you don't enter a password for the root user and get an error, this depends
on your MySQL configuration and is correct as well. If you've set a password
after installing MySQL, then you must enter that password as well. And in case
if no password has been set after MySQL installation, you must set one using
the appropriate command as you get told during MySQL installation. Everything
seems to be as expected, can't see your issue.
Comment 3 markm 2009-05-26 08:30:47 EDT
(In reply to comment #2)
> If http://127.0.0.1/phpMyAdmin/ works and http://localhost/phpMyAdmin/ doesn't
> work, this is an Apache configuration thing, which phpMyAdmin configuration can
> not trigger.

maybe because I am using VirtualHosts... on Fedora 10 I used virtual hosts too and could access phpMyAdmin via http://localhost/phpMyAdmin/ without any problems.

> If you don't enter a password for the root user and get an error, this depends
> on your MySQL configuration and is correct as well. If you've set a password
> after installing MySQL, then you must enter that password as well. And in case
> if no password has been set after MySQL installation, you must set one using
> the appropriate command as you get told during MySQL installation. Everything
> seems to be as expected, can't see your issue.  

mysql's root user had no password, so I expected phpMyAdmin to let me in with the username root and no password. when I set password for root user in mysql, phpMyAdmin accepted it and allowed me to manage data bases.
Comment 4 Bug Zapper 2009-06-09 12:34:48 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Robert Scheck 2009-06-14 13:46:13 EDT
On a plain Fedora 11 installation, phpMyAdmin installs works as expected and 
definately same as on Fedora 10. In case phpMyAdmin doesn't behave same, this 
is a local configuration issue at your system - sorry.

Note You need to log in before you can comment on or make changes to this bug.