Bug 502607 - system-config-selinux doesn't work any more: IndexError: tuple index out of range
system-config-selinux doesn't work any more: IndexError: tuple index out of r...
Status: CLOSED DUPLICATE of bug 502557
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 08:48 EDT by Eddie Lania
Modified: 2009-05-26 08:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-26 08:56:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eddie Lania 2009-05-26 08:48:04 EDT
Description of problem: system-config-selinux doesn't work any more. 

system-config-selinux 
/usr/share/system-config-selinux/system-config-selinux.py:72: Warning: IA__g_object_get_valist: object class `GnomeProgram' has no property named `default-icon'
  xml = gtk.glade.XML ("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 188, in <module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 91, in __init__
    self.add_page(portsPage.portsPage(xml))
  File "/usr/share/system-config-selinux/portsPage.py", line 69, in __init__
    self.load()
  File "/usr/share/system-config-selinux/portsPage.py", line 136, in load
    self.store.set_value(iter, PROTOCOL_COL, k[2])
IndexError: tuple index out of range



Version-Release number of selected component (if applicable):
setools-console-3.3.5-1.fc10.i386
setroubleshoot-plugins-2.0.12-1.fc10.noarch
setroubleshoot-2.0.12-3.fc10.noarch
selinux-policy-3.5.13-59.fc10.noarch
libsepol-2.0.33-1.fc10.i386
PolicyKit-0.9-4.fc10.i386
selinux-policy-targeted-3.5.13-59.fc10.noarch
PolicyKit-gnome-0.9-3.fc10.i386
setools-libs-3.3.5-1.fc10.i386
PolicyKit-gnome-libs-0.9-3.fc10.i386
setroubleshoot-server-2.0.12-3.fc10.noarch

How reproducible: Always


Steps to Reproduce:
1. open a terminal and as root launch system-config-selinux
2.
3.
  
Actual results: system-config-selinux doesn't work any more and spews the following on the screen:

/usr/share/system-config-selinux/system-config-selinux.py:72: Warning: IA__g_object_get_valist: object class `GnomeProgram' has no property named `default-icon'
  xml = gtk.glade.XML ("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 188, in <module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 91, in __init__
    self.add_page(portsPage.portsPage(xml))
  File "/usr/share/system-config-selinux/portsPage.py", line 69, in __init__
    self.load()
  File "/usr/share/system-config-selinux/portsPage.py", line 136, in load
    self.store.set_value(iter, PROTOCOL_COL, k[2])
IndexError: tuple index out of range



Expected results: No errors and a working system-config-selinux


Additional info:
Comment 1 Daniel Walsh 2009-05-26 08:56:55 EDT

*** This bug has been marked as a duplicate of bug 502557 ***

Note You need to log in before you can comment on or make changes to this bug.