Bug 502628 - TB0a0f70ae maindialog.py:602:hydrateProfiles:TypeError: sequence item not a string or unicode object
TB0a0f70ae maindialog.py:602:hydrateProfiles:TypeError: sequence item not a s...
Status: CLOSED DUPLICATE of bug 492915
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Harald Hoyer
BaseOS QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 10:51 EDT by Manuel Gil
Modified: 2009-09-02 10:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 10:16:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manuel Gil 2009-05-26 10:51:26 EDT
Description of problem:

When I change hosts file from another linux red hat enterprise 5.2 version, system-config-network get a crash. This hosts file is working well


Version-Release number of selected component (if applicable):

system-config-network 1.3.99.12


How reproducible:


Steps to Reproduce:
1.change /etc/hosts file from another linux red hat desktop older
2.I edit file, changing localhost, put local hostname
3.
  
Actual results:

the network toll is keeping out order

Expected results:

I thing that hosts file has something that make software crash in linux red hat 5.3 version

Additional info:
Comment 1 Siddhesh Poyarekar 2009-05-26 11:08:21 EDT
This is a dupe of bug #492915

Check your /etc/hosts for invalid entries. `man hosts` to see what constitutes a valid entry.
Comment 2 Manuel Gil 2009-05-26 11:29:51 EDT
then, why this file don't crash in older linux version, I check hosts file and didn't found wrong entries. I write ipaddress hostname, but I follow look in for diferences, because is sure that I have something wrong, but I don't understand, why in linux 5.2 is working whith the same hosts file
Comment 3 Siddhesh Poyarekar 2009-05-26 12:14:03 EDT
I'm not sure why but it looks like the entry is simply ignored in the older version. It's probably due to some change in behaviour of GtkCList -- looks like the earlier version accepted nulls. 

In any case, if you see the bug #492915, the upstream version (and Fedora) has introduced proper validation. We need to port it back into RHEL in some form.
Comment 4 Phil Knirsch 2009-09-02 10:16:50 EDT
Closing as dupe, and bug #492915 is the one we're tracking and currently proposing to get fixed for RHEL-5.5.

Thanks & regards, Phil

*** This bug has been marked as a duplicate of bug 492915 ***

Note You need to log in before you can comment on or make changes to this bug.