Bug 502671 - mirror creation asserts and core dumps if VG extent size and given log size are too small
mirror creation asserts and core dumps if VG extent size and given log size a...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.4
All Linux
high Severity high
: rc
: ---
Assigned To: Milan Broz
Cluster QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 16:27 EDT by Corey Marthaler
Modified: 2013-02-28 23:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:56:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
core file from the create attempt (672.00 KB, application/octet-stream)
2009-05-26 16:34 EDT, Corey Marthaler
no flags Details

  None (edit)
Description Corey Marthaler 2009-05-26 16:27:32 EDT
Description of problem:
Saw this while verifying bug 477040. If your VG has an extent size of only 1K, and you don't specify any space for the log ( :0-0 ) then you'll see this assertion.

[root@grant-03 ~]# vgcreate -s 1K grant /dev/sdb1 /dev/sdb2 /dev/sdb3 
  Volume group "grant" successfully created

[root@grant-03 ~]# lvcreate -L 64M -m 1 -n mirror grant /dev/sdb1 /dev/sdb2 /dev/sdb3:0-0
lvcreate: metadata/pv_map.c:190: consume_pv_area: Assertion `to_go <= pva->count' failed.
Aborted (core dumped)

This is reproducible.
Everytime 

Version-Release number of selected component (if applicable):
lvm2-2.02.46-2.el5
Comment 1 Corey Marthaler 2009-05-26 16:34:26 EDT
Created attachment 345516 [details]
core file from the create attempt
Comment 2 Milan Broz 2009-05-27 07:20:20 EDT
I sent some patch here
https://www.redhat.com/archives/lvm-devel/2009-May/msg00220.html

(I cannot reproduce segfault, but it should not reach assert code anyway).
Comment 4 Milan Broz 2009-06-01 11:09:26 EDT
Fixed upstream, setting bug to POST for now.
Comment 5 Milan Broz 2009-06-01 15:01:48 EDT
Fixed in lvm2-2_02_46-3_el5.
Comment 8 Corey Marthaler 2009-06-03 16:59:54 EDT
Fix verified in lvm2-2.02.46-3.el5.
Comment 10 errata-xmlrpc 2009-09-02 07:56:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1393.html

Note You need to log in before you can comment on or make changes to this bug.