Bug 502672 - [RHEL5] wireshark start-up very slow when forwarding X11 over ssh
[RHEL5] wireshark start-up very slow when forwarding X11 over ssh
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: wireshark (Show other bugs)
5.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Jan Safranek
BaseOS QE
:
Depends On:
Blocks: 743405 807971
  Show dependency treegraph
 
Reported: 2009-05-26 16:37 EDT by Jeff Bastian
Modified: 2012-04-16 02:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-16 02:50:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to increase update interval to 1 second (343 bytes, patch)
2009-05-26 16:38 EDT, Jeff Bastian
no flags Details | Diff
patch to increase update interval to 1 second for non-local $DISPLAY (1.44 KB, patch)
2009-05-26 16:38 EDT, Jeff Bastian
no flags Details | Diff

  None (edit)
Description Jeff Bastian 2009-05-26 16:37:13 EDT
Description of problem:
The wireshark splash screen updates very frequently as it loads plug-ins.  Over a slow network connection, this can stretch out the startup time from seconds to minutes due to the X11 chatter.

Attached are two alternative patches from Siddhesh Poyarekar that fix the problem.

1) wireshark-reduce-splash-update.patch: Increase the update interval to 1
second.

1)  wireshark-conditionally-reduce-splash-update.patch: Increase the update interval to 1 second if the $DISPLAY appears to be non-local, i.e., it contains more than ":x.y".


Version-Release number of selected component (if applicable):
wireshark-1.0.6-2.el5_3

How reproducible:
over a slow connection, every time

Steps to Reproduce:
1. ssh -X user@host
2. wireshark &
  
Actual results:
splash screen takes a long time to display

Expected results:
splash screen disappears as quickly as if running locally

Additional info:
Reported upstream at
  https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=3483

Upstream discussion at
  http://www.mail-archive.com/wireshark-dev@wireshark.org/msg13153.html
Comment 1 Jeff Bastian 2009-05-26 16:38:07 EDT
Created attachment 345518 [details]
patch to increase update interval to 1 second
Comment 2 Jeff Bastian 2009-05-26 16:38:38 EDT
Created attachment 345519 [details]
patch to increase update interval to 1 second for non-local $DISPLAY
Comment 3 Jeff Bastian 2009-05-26 17:14:15 EDT
Also from Siddhesh, a slow network can be simulated with cbq (provided by iproute) on the local system (the system displaying Wireshark, not running it).

1. Create an /etc/sysconfig/cbq/cbq-0010.rules file with contents similar to the following.  Make adjustments to DEVICE and RULE as necessary.
DEVICE=eth0,100Mbit,10Mbit
RATE=20Kbit
WEIGHT=2Kbit
PRIO=5
RULE=192.168.1.0/24

2. su -c '/sbin/cbq restart'
Comment 4 Radek Vokal 2009-05-27 10:37:19 EDT
Thanks for your report. THis has been resolved upstream but I'll keep this bug open so it can be mentioned in next wireshark update.
Comment 6 RHEL Product and Program Management 2009-11-06 13:49:16 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 RHEL Product and Program Management 2010-08-09 14:45:52 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 10 RHEL Product and Program Management 2011-05-31 09:53:09 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 RHEL Product and Program Management 2011-09-22 20:23:07 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 RHEL Product and Program Management 2012-04-02 06:30:06 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 14 Karel Srot 2012-04-12 09:29:20 EDT
Since this has been already fixed upstream and we have the fixes applied in wireshark-1.0.15, is there any reason for keeping this bug open?
Comment 15 Jeff Bastian 2012-04-13 14:48:20 EDT
This probably should have been closed with the rebase to 1.0.15 in bug 612239

Note You need to log in before you can comment on or make changes to this bug.