Bug 502685 - xorg option "DontZap" set to "false" works in gdm but not with a user session
xorg option "DontZap" set to "false" works in gdm but not with a user session
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Hutterer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 18:59 EDT by Charles-Henri d'Adhémar
Modified: 2009-05-29 05:01 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 18:48:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log file (105.64 KB, text/plain)
2009-05-26 18:59 EDT, Charles-Henri d'Adhémar
no flags Details

  None (edit)
Description Charles-Henri d'Adhémar 2009-05-26 18:59:01 EDT
Created attachment 345542 [details]
Xorg log file

Description of problem:

According to the documentation found in the release notes for Fedora 11 I modified my xorg.conf file to make the CTRL+ALT+Backspace shortcut work since it is deactivated by default in F11.
I restarted the computer after the change.
The shortcut works while at the gdm login but does not work when I am logged in a Gnome session.

Version-Release number of selected component (if applicable):

F11
xorg-x11-drv-dummy-0.3.1-2.fc11.x86_64
xorg-x11-drv-elographics-1.2.3-2.fc11.x86_64
xorg-x11-drv-fpit-1.3.0-2.fc11.x86_64
xorg-x11-xkb-utils-7.2-8.fc11.x86_64
xorg-x11-drv-synaptics-1.1.0-7.fc11.x86_64
xorg-x11-drv-mga-1.4.10-1.fc11.x86_64
xorg-x11-drv-cirrus-1.2.0-6.fc11.x86_64
xorg-x11-drv-s3virge-1.10.2-2.fc11.x86_64
xorg-x11-drv-vmmouse-12.6.3-4.fc11.x86_64
xorg-x11-drv-i128-1.3.0-2.fc11.x86_64
xorg-x11-server-utils-7.4-7.fc11.x86_64
xorg-x11-xinit-1.0.9-7.fc11.x86_64
xorg-x11-font-utils-7.2-7.fc11.x86_64
xorg-x11-drivers-7.3-11.fc11.x86_64
xorg-x11-utils-7.4-4.fc11.x86_64
xorg-x11-drv-voodoo-1.2.1-2.fc11.x86_64
xorg-x11-drv-trident-1.3.1-2.fc11.x86_64
xorg-x11-drv-sisusb-0.9.1-2.fc11.x86_64
xorg-x11-drv-v4l-0.2.0-2.fc11.x86_64
xorg-x11-drv-penmount-1.4.0-2.fc11.x86_64
xorg-x11-drv-fbdev-0.4.0-4.fc11.x86_64
xorg-x11-drv-ast-0.87.0-2.fc11.x86_64
xorg-x11-drv-i740-1.2.0-3.fc11.x86_64
xorg-x11-drv-intel-2.7.0-6.fc11.x86_64
xorg-x11-server-common-1.6.1.901-1.fc11.x86_64
xorg-x11-drv-savage-2.2.1-1.fc11.x86_64
xorg-x11-drv-evdev-2.2.1-3.fc11.x86_64
xorg-x11-filesystem-7.3-4.fc11.noarch
xorg-x11-drv-void-1.2.0-1.fc11.x86_64
xorg-x11-drv-acecad-1.3.0-1.fc11.x86_64
xorg-x11-drv-siliconmotion-1.7.0-1.fc11.x86_64
xorg-x11-drv-aiptek-1.2.0-1.fc11.x86_64
xorg-x11-drv-mutouch-1.2.1-2.fc11.x86_64
xorg-x11-drv-vmware-10.16.0-3.fc11.x86_64
xorg-x11-drv-mach64-6.8.0-3.fc11.x86_64
xorg-x11-drv-keyboard-1.3.2-3.fc11.x86_64
xorg-x11-drv-radeonhd-1.2.5-2.8.20090411git.fc11.x86_64
xorg-x11-drv-r128-6.8.0-3.fc11.x86_64
xorg-x11-drv-sis-0.10.1-2.fc11.x86_64
xorg-x11-drv-nouveau-0.0.12-36.20090514git9656762.fc11.x86_64
xorg-x11-drv-glint-1.2.2-2.fc11.x86_64
xorg-x11-drv-rendition-4.2.1-2.fc11.x86_64
xorg-x11-drv-mouse-1.4.0-2.fc11.x86_64
xorg-x11-server-Xorg-1.6.1.901-1.fc11.x86_64
xorg-x11-drv-tdfx-1.4.1-2.fc11.x86_64
xorg-x11-drv-apm-1.2.1-2.fc11.x86_64
xorg-x11-drv-hyperpen-1.3.0-1.fc11.x86_64
xorg-x11-drv-nv-2.1.13-1.fc11.x86_64
xorg-x11-drv-openchrome-0.2.903-10.fc11.x86_64
xorg-x11-drv-vesa-2.2.0-3.fc11.x86_64
xorg-x11-xauth-1.0.2-6.fc11.x86_64
xorg-x11-drv-ati-6.12.2-14.fc11.x86_64

How reproducible:
 Always

Steps to Reproduce:
1.Modify the xorg.conf and put 
Section "ServerFlags"
	Option "DontZap" "off"
EndSection

2. Restart the computer
3. At the gdm login enter CTRL+ALT+Backspace, it restarts X
4. Log into a Gnome session (using gdm), try CTRL+ALT+Backspace it does not work.
  
Actual results:

Cannot restart X, I have to do a "hard reset" which is not the best for my hardware ...

Expected results:

CTRL+ALT+Backspace just works like before in F10

Additional info:

Xorg.conf :

# Xorg configuration created by system-config-display

Section "ServerFlags"
	Option "DontZap" "off"
EndSection

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "fr"
	Option	    "XkbVariant" "latin9"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "radeonhd"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

I am using F11 X86_64, my video card is an ATI Radeon HD 3450 (RV620), and I am using the xorg-x11-drv-radeonhd driver
Comment 1 Charles-Henri d'Adhémar 2009-05-26 19:00:51 EDT
I forgot to say "Hello !" and "Thank you for your help !"
Sorry guys !
Comment 2 Matěj Cepl 2009-05-27 16:56:00 EDT
It is easier to use System/Keyboard/Layout/Options of the layout/Key sequence to kill X server. Does it work for you?
Comment 3 Peter Hutterer 2009-05-27 18:48:35 EDT
The key combination Ctrl+Alt+Backspace to kill the X server has been removed from the default XKB maps. To restore it, you must enable the xkb option terminate:ctrl_alt_bksp. From the main menu, select System > Preferences > Keyboard. In the Keyboard Preferences dialog, select the Layout tab, then select Layout Options. Select Key sequence to kill the X server and then tick the checkbox for Control + Alt + Backspace.

Alternatively, run the following command to enable the key combination temporarily:

setxkbmap -option "terminate:ctrl_alt_bksp"

From https://fedoraproject.org/wiki/Documentation_Xorg_Beat


The option DontZap enables or disables the possibility of zapping the server altogether, i.e. if DontZap is enabled (and zapping is thus disabled) you cannot zap the server even if the matching XKB symbol is present. In the default setting, DontZap is disabled but the XKB symbol is not present unless enabled.
Comment 4 Charles-Henri d'Adhémar 2009-05-28 13:27:26 EDT
It worked great !
Thank you very much to all of you.

Do you think it should be mentionned in the release notes since it only mentions the Xorg configuration part, not the desktop environment part ?

Cheers,
CH
Comment 5 Peter Hutterer 2009-05-28 18:22:06 EDT
i think it will be, but the final release notes aren't out yet and this behaviour was changed after the pre-release.
Comment 6 Charles-Henri d'Adhémar 2009-05-29 05:01:17 EDT
Ok, great.
Thanks Peter for your help and all your work on Fedora.
I wish you all the best for F11 !

Note You need to log in before you can comment on or make changes to this bug.