Bug 502806 - switch to using PolicyKit
switch to using PolicyKit
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: backintime (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: hannes
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 05:23 EDT by Rahul Sundaram
Modified: 2016-02-29 06:10 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 06:10:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rahul Sundaram 2009-05-27 05:23:57 EDT
Description of problem:

usermode/consolehelper is deprecated since Fedora has a better framework now
called PolicyKit. Please switch to using that instead

http://fedoraproject.org/wiki/Features/PolicyKitOne
Comment 1 Simon 2009-05-28 08:53:17 EDT
I'm tending to close this as "won't fix" or "not a bug"

(In reply to comment #0)
> Fedora has a better framework now called PolicyKit. 
Is it really better? It's sound like PackageKit and PackageKit isn't a good thing!

I see no advantage for a switch to policykit right now. Let's talk about this in a few months or in a few releases.
Comment 2 John Poelstra 2009-06-08 16:18:57 EDT
Added 'FutureFeature' keyword to avoid rawhide base
Comment 3 Tim Jackson 2012-07-21 16:20:05 EDT
Having followed the Fedora feature link, looked briefly at the PolicyKit documentation and searched online for things like "PolicyKit usermode porting guide", I'm still none the wiser about how a packager migrates a working application from usermode/consolehelper to PolicyKit.

Can you offer any links to reasonably straightforward guides on how to do this that don't involve becoming a PolicyKit expert?
Comment 5 Christopher Meng 2013-09-26 00:19:53 EDT
Hi Rahul.

How can we switch to using PK?

Any howto available?
Comment 6 Fedora Admin XMLRPC Client 2013-12-23 19:48:40 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 germar.reitze 2015-09-28 12:57:41 EDT
I changed BackInTime to PolicyKit upstream in version 1.1.0
Current version at time of writing is 1.1.6
Comment 8 Fedora Admin XMLRPC Client 2016-02-19 13:13:47 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2016-02-19 16:40:32 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Raphael Groner 2016-02-28 17:30:24 EST
Has this bug still any relevance, or can we close?
Comment 11 germar.reitze 2016-02-28 17:36:43 EST
I fixed this upstream. So if you upgraded to BIT >= 1.1.0 you can close this.

Note You need to log in before you can comment on or make changes to this bug.