Bug 502865 - Firefox is having trouble recovering your windows and tabs
Firefox is having trouble recovering your windows and tabs
Status: CLOSED DUPLICATE of bug 437596
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 11:03 EDT by Orion Poplawski
Modified: 2009-06-17 15:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-17 15:28:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-05-27 11:03:20 EDT
Description of problem:

Everytime I reboot with firefox running, on login I get:

Well, this is embarrassing.

Firefox is having trouble recovering your windows and tabs. This is usually caused by a recently opened web page.

Running KDE desktop with manually saved session.

[root@orca ~]# ps -fe | grep firefox
orion     2377  2335  0 08:55 ?        00:00:00 /bin/sh /usr/lib/firefox-3.5b4/run-mozilla.sh /usr/lib/firefox-3.5b4/firefox --sm-config-prefix /firefox-O4Kqxb/ --sm-client-id 106f726361000123393768500000029380043 --screen 0
orion     2525  2377  8 08:55 ?        00:00:06 /usr/lib/firefox-3.5b4/firefox --sm-config-prefix /firefox-O4Kqxb/ --sm-client-id 106f726361000123393768500000029380043 --screen 0

Hmm, this might be a KDE issue:

.kde/share/config/ksmserverrc:program11=firefox
.kde/share/config/ksmserverrc:restartCommand11=firefox,--sm-config-prefix,/firefox-Vp9CrZ/,--sm-client-id,106f726361000123299017500000072300016,--screen,0
.kde/share/config/ksmserverrc:program5=firefox
.kde/share/config/ksmserverrc:restartCommand5=firefox,--sm-config-prefix,/firefox-8oV6Z9/,--sm-client-id,106f726361000123393768500000029380043,--screen,0

Why two firefox restart commands?  Probably getting this from firefox session registration though....

I'll try removing one of the firefox restart commands.

Version-Release number of selected component (if applicable):
firefox-3.5-0.20.beta4.fc11.i586
kdebase-4.2.3-1.fc11.i586

How reproducible:
Everytime
Comment 1 Matěj Cepl 2009-05-27 17:06:28 EDT

*** This bug has been marked as a duplicate of bug 437596 ***
Comment 2 Orion Poplawski 2009-05-28 11:48:20 EDT
Nope.  I can reproduce this simply by killing firefox and then restarting it.
Comment 3 Bug Zapper 2009-06-09 12:38:26 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Michael S. Tsirkin 2009-06-17 04:42:02 EDT
Yes, I'm seeing this every time on FC 11, too.
Comment 5 Matěj Cepl 2009-06-17 15:25:35 EDT
(In reply to comment #2)
> Nope.  I can reproduce this simply by killing firefox and then restarting it.  

Yes, and that's the same as bug I close it duplicate of.

*** This bug has been marked as a duplicate of bug 437596 ***
Comment 6 Matěj Cepl 2009-06-17 15:28:49 EDT
No, this is correct. Firefox just doesn't work well with KDE session management, which is the upstream bug we closed duplicate of this bug against.

*** This bug has been marked as a duplicate of bug 437596 ***

Note You need to log in before you can comment on or make changes to this bug.