Bug 502929 - shorewall6 is not starting because of missing /var/lib/shorewall6
shorewall6 is not starting because of missing /var/lib/shorewall6
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: shorewall (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Underwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 16:01 EDT by Peter Bieringer
Modified: 2009-06-04 17:13 EDT (History)
1 user (show)

See Also:
Fixed In Version: 4.2.9-2.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 17:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2009-05-27 16:01:36 EDT
Description of problem:
shorewall6 is not starting because of missing /var/lib/shorewall6

Version-Release number of selected component (if applicable):

Fedora 10:
shorewall6-4.2.7-5.fc11.noarch

Fedora 11.
shorewall6-4.2.7-3.fc10.noarch

How reproducible:
Always

Steps to Reproduce:
1. install shorewall6
2. create a ruleset
3. start shorewall6
  
Actual results:
# LC_ALL=C /etc/init.d/shorewall6 restart
Restarting Shorewall:                                      [FAILED]

/var/log/messages:
May 27 21:59:47 f10-router shorewall6[1757]: Compiling...
May 27 21:59:48 f10-router shorewall6[1757]:    ERROR: Directory /var/lib/shorewall6/ does not exist
May 27 21:59:48 f10-router root: ERROR:Shorewall6 restart failed


Expected results:
Starting proper.

Additional info:

Wrong directory is included:
# rpm -ql shorewall6 |grep "/var/lib"
/var/lib/shorewall

Workaround:

mkdir /var/lib/shorewall6
Comment 1 Fedora Update System 2009-05-27 17:48:05 EDT
shorewall-4.2.9-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/shorewall-4.2.9-2.fc11
Comment 2 Fedora Update System 2009-05-27 17:48:09 EDT
shorewall-4.2.9-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/shorewall-4.2.9-2.fc10
Comment 3 Fedora Update System 2009-05-29 22:28:31 EDT
shorewall-4.2.9-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update shorewall'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-5658
Comment 4 Fedora Update System 2009-05-29 22:35:49 EDT
shorewall-4.2.9-2.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update shorewall'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-5695
Comment 5 Jonathan Underwood 2009-06-02 18:14:07 EDT
Looks like that fixes things. Thanks for the report and testing.
Comment 6 Fedora Update System 2009-06-04 17:13:13 EDT
shorewall-4.2.9-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2009-06-04 17:13:40 EDT
shorewall-4.2.9-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.