Bug 502945 - install from livecd ext3 / ext4 catch-22
install from livecd ext3 / ext4 catch-22
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 17:35 EDT by kilolima
Modified: 2009-05-29 00:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-27 19:33:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kilolima 2009-05-27 17:35:46 EDT
Description of problem:

When installing from the xfce F11 livecd preview, attempting to create an ext4 / partition results in an error about being unable to install the boot partition to an ext4 partition.  Am unwilling to create a separate small ext3 partition because already at logical partition maximum and dislike LVM, and other distros do not have this limitation.

When attempting to create and install / to an ext3 partition, the installer reports an error that it can only install to ext4 to match the livecd image or something? 

(sorry don't have actual error messages as the firefox on the livecd seg faults)

Version-Release number of selected component (if applicable):

10.92

How reproducible:
boot livcd
run installer
create / as ext4

or

create / as ext3

Steps to Reproduce:
1.
2.
3.
  
Actual results:

cannot install.


Expected results:

I would expect the installer to install to a single ext4 or ext3 partition.

It would also be nice if I could specify my pre-existing encrypted ext3 /home directory during the install as well.
 
Additional info:
Comment 1 Jeremy Katz 2009-05-27 19:33:28 EDT
Installing from the live image requires that you have a matching rootfs type to the live image -- ext4 in the case of F11.  Since the grub support for ext4 hasn't landed, this means you also need a separate ext3 /boot.
Comment 2 kilolima 2009-05-29 00:52:44 EDT
yes, and this is why it's a catch-22!  Can't boot from ext4 and can't install to ext3 - so then the user has to create additional partitions when all that should really be needed is one (and swap).

Note You need to log in before you can comment on or make changes to this bug.