Bug 502951 - Cannot bring up network using NetworkManager during initial install.
Cannot bring up network using NetworkManager during initial install.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 18:03 EDT by Ruth Ivimey-Cook
Modified: 2009-11-11 12:44 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-11 12:44:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ruth Ivimey-Cook 2009-05-27 18:03:38 EDT
Description of problem:
Using F11 Preview DVD.
Cannot bring up network using NetworkManager: after a timeout of about 1 min it says there is an error (but is non-specific as to what).

I can use ifconfig & route from the shell to configure the network and it works perfectly well. However, the fact that Anaconda insists on using NM to configure the network means I can't install F11 (i.e. I can't even configure myself and skip NM configuration).

Version-Release number of selected component (if applicable):
Unknown. Whatever Anaconda/F11 is using...

How reproducible:
Repros. every time on my system (Asus A8N-SLI/Athlon 64 Dual 4400). The system has 2 GB network interfaces, Marvell and nForce; I can configure both manually but neither using NM.

Steps to Reproduce:
1. Boot installer from DVD
2. ... enter TZ, root PW, disk layout etc ... request for network settings...
3. Enter settings. DHCP or not makes no difference. eth0 / eth1 makes no difference.
  
Additional info:
Comment 1 Ruth Ivimey-Cook 2009-05-27 18:51:01 EDT
I tried providing network info on the command line ("linux ip=xxx netmask=xxx ...") but this seems to be ignored; I am still prompted for NetworkManager settings, which still fail with "An error occurred setting up eth0".

One Q: the dialog says that I need network access to get to repos I've selected, but I have a DVD spin and haven't added any additional repos. What's worse, lack of the network is a fatal error to the install. Why can't I just ignore the network repos and install what I've got?
Comment 2 Niels Haase 2009-05-30 06:59:45 EDT
Thanks for filling this bug.
Reporter, can you please get the last RC (RC 2) from this page
http://alt.fedoraproject.org/pub/alt/stage/f11-rc2/
and give it a try. There are many changes from the Preview to the RC, maybe your problem is already fixed.

Thanks

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Ruth Ivimey-Cook 2009-06-05 04:18:13 EDT
I downloaded the above rc2 but my burning software complained that its format was invalid; I now can't find any rc2 or 3 to re-download.

I would simply suggest that there were some way to override NM in the install process -- perhaps the kernel ip=..., so if there are probs there is a workaround.
Comment 4 Bug Zapper 2009-06-09 12:41:35 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Peter McNabb 2009-06-10 00:14:24 EDT
This is still a problem in F11 release. During PPC (PowerBook G4) netinstall, I can't use DHCP or static settings in anaconda to bring up the network interface, but I can switch to a shell and run dhclient on eth0. There doesn't seem to be a way to get past the network setup screen after I have it manually configured.
Comment 6 Peter McNabb 2009-06-10 10:33:36 EDT
The network was configured properly when I used the text installer.
Comment 7 Niels Haase 2009-06-17 07:08:07 EDT
Reporter, can you please try to install with the "asknetwork" anaconda option set?

If the menu of grub menu of the DVD is show, press TAB and and attach the "asknetwork" on the given prompt.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Jonathan Leung-Nilsson 2009-10-22 16:06:33 EDT
This problem still exists in the F12 Beta.

I used the netinstall CD; Anaconda loads fine through all the initial setup steps (time zone, partitioning, root password, etc) but fails when attempting to setup the network using a static IP.

I can press Ctrl-Alt-F2 to get the console and use 'ifconfig eth0 10.1.1.2 netmask 255.255.255.0' and then 'route add default gw 10.1.1.1' to get network manually.  But Anaconda cannot continue because NetworkManager still fails when I press Alt-F6 to go back to the GUI.
Comment 9 James Nguyen 2009-10-22 20:15:39 EDT
I'm getting this problem kickstarting both in VMware and Xen.  This is for 12 beta.  Works on 11 though. When I switch to alt+f4 I'll see messages like

... NetworkManager:  ifcfg-rh:   error: unknown BOOTPROTO 'static'

In my kickstart command line I'm passing in a static ip/netmask/etc just like I have with fedora 11 and that one works fine.  Seems like fedora 12 introduced a problem with kickstarting when using a static network config?
Comment 10 Dan Williams 2009-10-23 13:34:45 EDT
(In reply to comment #8)
> This problem still exists in the F12 Beta.
> 
> I used the netinstall CD; Anaconda loads fine through all the initial setup
> steps (time zone, partitioning, root password, etc) but fails when attempting
> to setup the network using a static IP.
> 
> I can press Ctrl-Alt-F2 to get the console and use 'ifconfig eth0 10.1.1.2
> netmask 255.255.255.0' and then 'route add default gw 10.1.1.1' to get network
> manually.  But Anaconda cannot continue because NetworkManager still fails when
> I press Alt-F6 to go back to the GUI.  

This specific issue with static IP during install is an F-12 specific issue (bug 528068), and is fixed in current F12 rawhide with:

http://koji.fedoraproject.org/koji/taskinfo?taskID=1762133
Comment 11 Dan Williams 2009-10-23 13:35:56 EDT
Same for your problem, James Nguyen.  Latest F12 updates in rawhide fix that bug.

I believe the F11 bug is different though.
Comment 12 James Nguyen 2009-10-23 16:13:27 EDT
Thanks Dan!

Do you know when the changes will make it out for my network installs? Right now I'm using one of the mirrors from USC, so I figured they'd have to sync up as well.
Comment 13 Dan Williams 2009-10-23 16:33:51 EDT
They should be in rawhide as of October 23rd:

http://download.fedora.redhat.com/pub/fedora/linux/development/i386/os/Packages/NetworkManager-0.7.996-5.git20091021.fc12.i686.rpm

Verify that's the version your mirrors have, and that your net/boot ISO is dated at least October 23rd.
Comment 14 Dan Williams 2009-11-11 12:44:44 EST
Ruth, please re-open if this happens with Fedora 12 as I'm quite sure it's been fixed there.  If you still run into the bug, you can get some logs out of the machine by switching to a different Virtual Terminal (VT) with the Ctl+Alt+Fx keys.  There should be one (try F1 through F7) on which NetworkManager logs are displayed (F5 I think).  If you could copy down those messages when you get the error about configuring the network and paste them into this bug report that would be quite helpful.

Note You need to log in before you can comment on or make changes to this bug.