This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 502962 - update hplip to latest release 3.9.6
update hplip to latest release 3.9.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
http://hplipopensource.com/
:
: 512419 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-05-27 20:26 EDT by acount closed by user
Modified: 2009-07-27 14:24 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-27 14:24:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description acount closed by user 2009-05-27 20:26:50 EDT
Significant Changes

    * Add Designjet support for selected Designjet printers
    * Added PolicyKit support - command line tools like hp-setup, hp-plugin, etc. are now run as a regular user, not root/superuser
    * Added GPG digital signature support to the the HPLIP plug-in. This feature validates that the plug-in is not corrupted and is authentic prior to installation.
    * Added native CUPS driver support (hpcups). Currently this support should be used for testing only.
    * A lot of bugs fixed


Added Support for the Following New Printers:

    * HP LaserJet p1009 Printer (LJP1XXX) (REQURIES plug-in)
    * HP Designjet 4020ps (Postscript)
    * HP Designjet 4520ps (Postscript)
    * HP Designjet 4520mfp (Postscript) (Note: PC send fax not supported in this release)
    * HP Officejet 6500 All-in-one Printer - e709a (DJGenericVIP)
    * HP Officejet 6500 Wireless All-in-one Printer - e709n (DJGenericVIP)

complete changelog at: http://hplipopensource.com/hplip-web/release_notes.html

-thanks-
Comment 1 Bug Zapper 2009-06-09 12:41:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Randall "Randy" Berry 2009-06-19 14:56:44 EDT
Current is actually HPLIP 3.9.6

http://hplipopensource.com/hplip-web/release_notes.html

Significant Changes

* The new native CUPS driver (HPCUPS) is now the default printer driver. HPCUPS requires CUPS 1.2 or higher and is a complete replacement for HPIJS. For now HPIJS is still included in the tarball and if necessary can co-exist with HPCUPS. HPCUPS provides new paper sizes for borderless and duplex. This means we now have PPDs with exact printable regions for normal, borderless and duplex paper sizes.

* A new utility 'hp-wificonfig' allows you to configure select wifi-capable printers on a wireless network. Once configured, the printer may be installed normally using hp-setup (there is also a way to access hp-wificonfig directly from hp-setup).
Comment 3 acount closed by user 2009-06-19 15:14:09 EDT
(In reply to comment #2)

> Current is actually HPLIP 3.9.6
> 
> http://hplipopensource.com/hplip-web/release_notes.html
> 
> Significant Changes


plus support for 36 new printers.
Comment 4 Tim Waugh 2009-07-20 04:55:59 EDT
*** Bug 512419 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.