Bug 502971 - Man page for chattr(1) missing some attributes
Man page for chattr(1) missing some attributes
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-27 21:04 EDT by Neil
Modified: 2009-05-30 23:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-30 23:58:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neil 2009-05-27 21:04:41 EDT
Description of problem:
The manual page for chattr(1) says:
    "The format of a symbolic mode is +-=[ASacDdIijsTtu]."
It would be nice if this list was sorted (i.e. put "S" in the correct place)
    "The letters 'acdijsuADST' select the  new  attributes  for  the  files"
This list doesn't match the list above; "I" and "t" are missing.  Also, it should be sorted the same as above (i.e. both case-insensitive or both case sensitive).
Also, "lsattr" shows 15 dashes, but these lists only show 13 attributes.  Are there two more that are missing?

Version-Release number of selected component (if applicable):
e2fsprogs-1.41.4-10.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
1. "man chattr"
2.
3.
  
Actual results:
"I" and "t" are not shown in the list in the man page.

Expected results:
All attributes are documented.  Are there 15 or 13 or them?

Additional info:
Comment 1 Eric Sandeen 2009-05-28 00:25:23 EDT
Sent a patch upstream.  

a previous patch:
http://article.gmane.org/gmane.comp.file-systems.ext4/10877

and mine:
http://thread.gmane.org/gmane.comp.file-systems.ext4/13476

should do the trick.
Comment 2 Eric Sandeen 2009-05-28 00:28:08 EDT
It now reads:

DESCRIPTION
       chattr changes the file attributes on a  Linux  second  extended  file
       system.

       The format of a symbolic mode is +-=[acdeijstuADST].

       The  operator  ‘+’  causes  the selected attributes to be added to the
       existing attributes of the files; ‘-’ causes them to be  removed;  and
       ‘=’ causes them to be the only attributes that the files have.

       The  letters  ‘acdeijstuADST’ select the new attributes for the files:
       append only (a), compressed (c),  no  dump  (d),  extent  format  (e),
       immutable  (i),  data  journalling  (j), secure deletion (s), no tail-
       merging (t), undeletable (u), no atime updates (A), synchronous direc-
       tory  updates (D), synchronous updates (S), and top of directory hier-
       archy (T).

       The following attributes are read-only, and may be listed by lsattr(1)
       but  not  modified  by  chattr:  huge file (h), compression error (E),
       indexed directory (I), compression  raw  access  (X),  and  compressed
       dirty file (Z).

re: the 13/15 question, it's a bit messy because the compression attributes aren't always all built in... but there are (or will be) 13 settable (acdeijstuADST) and 2 more readable (h and I) in the Fedora build, for a total of 15.

Thanks,
-Eric

Note You need to log in before you can comment on or make changes to this bug.