Bug 503034 - bug FC10 install with kickstat file and software RAID - mdmonitor freeze during boot
bug FC10 install with kickstat file and software RAID - mdmonitor freeze duri...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 08:31 EDT by popbug
Modified: 2009-05-29 14:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 14:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart used for installation (4.84 KB, text/plain)
2009-05-28 08:39 EDT, popbug
no flags Details

  None (edit)
Description popbug 2009-05-28 08:31:36 EDT
Description of problem:

when installing FC10 with kickstart with raid software raid, after the installation the system do not start. it freeze during boot when just afte displaying "mdmonitor".
Server used = Dell PowerEdge 860 with 2 Hard drive in SATA (sda and sdb)

I have found a way to bypass this problem, 
    - boot in single-user mode 
    - write a file on the disk
    - reboot the server
and the system reboot correctly!

But it can be done only if physical access to the server, and I use kickstart to install server with PXE remotly (we have 2 server in every countries).

The kickstart file was OK with FC4 and FC6 and do not work anymore with FC10

Version-Release number of selected component (if applicable):
tested with "FC10 DVD" and "FC10-unity 20090414"


How reproducible:
install with this kickstart file !

Steps to Reproduce:
1. install with kickstart file
2. see that it is not booting properly

  
Actual results:
/

Expected results:
to be able to install and server to reboot !!!

Additional info:
in case of problem with the fille attachment, kickstart content
================================================================
#platform=x86, AMD64, or Intel EM64T

#interactive

#System  language
lang en_US

#Language modules to install
lang en_US

#System keyboard
keyboard us

#System mouse

#Sytem timezone
timezone Europe/Paris

#Root password
rootpw turlututu

#Reboot after installation
reboot

#Use text mode install 
text

#Install OS instead of upgrade
install

#use CD for installation
cdrom

# Run the Setup Agent on first boot
firstboot --enable

#System bootloader configuration
bootloader --location=mbr

#Clear the Master Boot Record
zerombr yes 

#Partition clearing information
clearpart --all --initlabel  

#Disk partitioning information
part raid.11 --size=8192 --ondisk=sda
part raid.21 --size=8192 --ondisk=sdb
part raid.20 --size=2048 --ondisk=sdb
part raid.10 --size=2048 --ondisk=sda
part raid.22 --size=1 --grow --ondisk=sdb
part raid.12 --size=1 --grow --ondisk=sda
raid swap --fstype swap --level=RAID1 --device=md0 raid.10 raid.20
raid / --fstype ext3 --level=RAID1 --device=md1 raid.11 raid.21
raid /var --fstype ext3 --level=RAID1 --device=md2 raid.12 raid.22

#System authorization infomation
auth  --useshadow  --passalgo=md5 

#Network information 
network --device=eth0 --bootproto=static --ip=192.168.0.254 --netmask=255.255.255.0 --gateway=192.168.0.1 --hostname=$hostname
network --device=eth1 --bootproto=static --ip=10.10.10.100  --netmask=255.255.255.0 --gateway=10.10.10.10

#Firewall configuration
firewall --disabled --trust=eth0 --trust=eth1 --ssh

#SELinux configuration
selinux --disabled

#Do not configure XWindows
skipx

#Package install information
%packages
@development-tools
libtiff
libtiff-devel
libjpeg
libjpeg-devel
ncurses
ncurses-devel
openssl
openssl-devel


#Network information
%pre


%post
echo "#!/bin/bash" > /etc/profile.d/netconf.sh
echo "ln -s /usr/src/kernels/*/ /usr/src/linux" >> /etc/profile.d/netconf.sh
echo "ln -s /usr/src/kernels/*/include/linux/compiler.h /usr/include/linux/compiler.h"  >> /etc/profile.d/netconf.sh
echo "echo 'Desactivation of un-necessary services (netfs, pcsd, rpcgssd, rpcidmapd, rpcsvcgssd, haldaemon, cups, NetworkManager, bluetooth)'" >> /etc/profile.d/netconf.sh
echo -e "chkconfig netfs off \n chkconfig pcscd off \n chkconfig rpcgssd off \n chkconfig rpcidmapd off \n chkconfig rpcsvcgssd off\n chkconfig haldaemon off \n chkconfig cups off \n  chkconfig NetworkManager off \n chkconfig network on \n chkconfig bluetooth off " >> /etc/profile.d/netconf.sh
echo "echo -ne 'Hostname:' " >> /etc/profile.d/netconf.sh
echo "read hostname " >> /etc/profile.d/netconf.sh
echo "echo 'ATTENTION!!! eth0 must be connected to Internet, eth1 must be connected to trusted network!'" >> /etc/profile.d/netconf.sh
echo "echo -ne 'eth0 IP-address:'" >> /etc/profile.d/netconf.sh
echo "read eth0_ip" >> /etc/profile.d/netconf.sh
echo "echo -ne 'eth0 Netmask:'" >> /etc/profile.d/netconf.sh
echo "read eth0_nm" >> /etc/profile.d/netconf.sh
echo "echo -ne 'eth0 Internet-gateway:'" >> /etc/profile.d/netconf.sh
echo "read eth0_gw" >> /etc/profile.d/netconf.sh
echo "echo -ne 'eth1 IP-address:'" >> /etc/profile.d/netconf.sh
echo "read eth1_ip" >> /etc/profile.d/netconf.sh
echo "echo -ne 'eth1 Netmask:'" >> /etc/profile.d/netconf.sh
echo "read eth1_nm" >> /etc/profile.d/netconf.sh
echo "echo -ne 'DNS1:'" >> /etc/profile.d/netconf.sh
echo "read dns1" >> /etc/profile.d/netconf.sh
echo "echo -ne 'DNS2 (enter for none):'" >> /etc/profile.d/netconf.sh
echo "read dns2" >> /etc/profile.d/netconf.sh
echo "echo 'NERWORKING=yes' > /etc/sysconfig/network" >> /etc/profile.d/netconf.sh
echo "echo 'HOSTNAME='\$hostname >> /etc/sysconfig/network" >> /etc/profile.d/netconf.sh
echo "echo 'GATEWAY='\$eth0_gw >> /etc/sysconfig/network" >> /etc/profile.d/netconf.sh
echo "echo 'DEVICE=eth0' > /etc/sysconfig/network-scripts/ifcfg-eth0" >> /etc/profile.d/netconf.sh
echo "echo 'BOOTPROTO=static' >> /etc/sysconfig/network-scripts/ifcfg-eth0" >> /etc/profile.d/netconf.sh
echo "echo 'IPADDR='\$eth0_ip >> /etc/sysconfig/network-scripts/ifcfg-eth0" >> /etc/profile.d/netconf.sh
echo "echo 'NETMASK='\$eth0_nm >> /etc/sysconfig/network-scripts/ifcfg-eth0" >> /etc/profile.d/netconf.sh
echo "echo 'ONBOOT=yes' >> /etc/sysconfig/network-scripts/ifcfg-eth0" >> /etc/profile.d/netconf.sh
echo "echo 'DEVICE=eth1' > /etc/sysconfig/network-scripts/ifcfg-eth1" >> /etc/profile.d/netconf.sh
echo "echo 'BOOTPROTO=static' >> /etc/sysconfig/network-scripts/ifcfg-eth1" >> /etc/profile.d/netconf.sh
echo "echo 'IPADDR='\$eth1_ip >> /etc/sysconfig/network-scripts/ifcfg-eth1" >> /etc/profile.d/netconf.sh
echo "echo 'NETMASK='\$eth1_nm >> /etc/sysconfig/network-scripts/ifcfg-eth1" >> /etc/profile.d/netconf.sh
echo "echo 'ONBOOT=yes' >> /etc/sysconfig/network-scripts/ifcfg-eth1" >> /etc/profile.d/netconf.sh
echo "echo 'nameserver' \$dns1 >> /etc/resolv.conf" >> /etc/profile.d/netconf.sh
echo "echo 'nameserver' \$dns2 >> /etc/resolv.conf" >> /etc/profile.d/netconf.sh
echo "reboot" >> /etc/profile.d/netconf.sh

%end
Comment 1 popbug 2009-05-28 08:39:24 EDT
Created attachment 345746 [details]
kickstart used for installation
Comment 2 Chris Lumens 2009-05-28 10:20:06 EDT
Is this better with F11?  There's been major storage rewriting done since F10 was released so it's likely your bug is fixed.
Comment 3 popbug 2009-05-28 17:45:13 EDT
problem seens to be resolved with FC11...

is the actual downloadable (downloaded today version a release candidate?

will it be a lot of change since the 9 of june ?
Comment 4 Chris Lumens 2009-05-29 14:12:35 EDT
Today's version is probably pretty close to the RC, if not identical.  Not much should have changed over the past couple days.  Glad it's working for you now.  Thanks for testing.

Note You need to log in before you can comment on or make changes to this bug.