Bug 503050 - Improper Requires: for java-1.5.0 in jbossas 4.3.0 rpm
Improper Requires: for java-1.5.0 in jbossas 4.3.0 rpm
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 4
Classification: JBoss
Component: jbossas (Show other bugs)
4.3.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Fernando Nasser
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 11:00 EDT by Tom Sorensen
Modified: 2015-09-21 00:11 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 00:11:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Sorensen 2009-05-28 11:00:15 EDT
Description of problem:
JBoss AS EAP 4.3.0 documentation states it is compatible with java 1.5.0 or java 1.6.0. However the RPMs require "java-1.5.0" and "java-1.5.0-devel". Should change spec file to require "java" or "jre" >= 1.5.0" and "java-devel" or "java-sdk" >= 1.5.0 so that it can be installed without needing 1.5 (which is only available on supplemental CD or RHN).

Version-Release number of selected component (if applicable):
jbossas-4.3.0-3.GA_CP03.6.2.ep1.el5

How reproducible:
Always

Steps to Reproduce:
1. Install java-1.6.0-sun and java-1.6.0-sun-devel or the openjdk packages
2. Attempt to install jbossas package

  
Actual results:
Dependancy failure for java-1.5.0 requirement.

Expected results:
Should install.
Comment 1 Tomas Herfert 2010-05-26 08:43:12 EDT
Dear JBoss team,
is there any progress on this bug? 

Thanks
Tomas

Note You need to log in before you can comment on or make changes to this bug.