Bug 503053 - virt-install --disk ...,device=floppy is busted
virt-install --disk ...,device=floppy is busted
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 11:08 EDT by Cole Robinson
Modified: 2009-12-14 16:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 11:29:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2009-05-28 11:08:40 EDT
In version python-virtinst-0.400.3-1.el5

Running:

virt-install --connect test:///default --name foo --ram 64 --pxe --nographics --noautoconsole --disk path=virt-install,device=floppy

Results in:

Starting install...
internal error Invalid floppy device name: hda
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start foo'; otherwise, please
 restart your installation.
ERROR    internal error Invalid floppy device name: hda
Traceback (most recent call last):
  File "./virt-install", line 865, in <module>
    main()
  File "./virt-install", line 763, in main
    start_time, guest.start_install)
  File "./virt-install", line 818, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/mnt/storage.bos/boston/crobinso/sandbox/rhel/python-virtinst/python-virtinst/RHEL-5/virtinst-0.400.3/virtinst/Guest.py", line 541, in start_install
    return self._do_install(consolecb, meter, removeOld, wait)
  File "/mnt/storage.bos/boston/crobinso/sandbox/rhel/python-virtinst/python-virtinst/RHEL-5/virtinst-0.400.3/virtinst/Guest.py", line 633, in _do_install
    self.domain = self.conn.createLinux(install_xml, 0)
  File "/usr/lib64/python2.5/site-packages/libvirt.py", line 1073, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Invalid floppy device name: hda


This is fixed upstream by commit, and has been there for a couple months now:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/fd4baa6410d8

Specifying floppy devices is new functionality introduced by the rebase, so this techincally isn't a regression (and by extension the bug hasn't existed in any released version).
Comment 1 Cole Robinson 2009-05-28 13:40:31 EDT
I should note that I feel the fix is very low risk: it has been upstream for 2 months, and in that time regression testing has greatly improved, so I have high confidence that this change doesn't cause other issues.
Comment 2 Cole Robinson 2009-06-08 11:29:42 EDT
Fixed in python-virtinst-0.400.3-2.el5. Closing as NEXTRELEASE, since this bug has
not existed in any released package as it was brought in by the rebase.

Note You need to log in before you can comment on or make changes to this bug.