Bug 503058 - proxy command, has a bad scp example command
proxy command, has a bad scp example command
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
na
: Reopened
Depends On:
Blocks: 456999
  Show dependency treegraph
 
Reported: 2009-05-28 11:30 EDT by wes hayutin
Modified: 2009-09-10 10:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:39:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-05-28 11:30:55 EDT
Description of problem:


5/21.1 build 

proxy installer states..

CA Chain [/usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT]: /usr/share/rhn/RHN-ORG-TRUSTED-SSL-CERT
/usr/sbin/configure-proxy.sh: line 215: [0: command not found
Please do copy your CA key and public certificate from grandprix.rhndev.redhat.com to 
/root/ssl-build directory. You may want to execute this command:
 mkdir ; scp 'root@grandprix.rhndev.redhat.com:/root/ssl-build/RHN-ORG-{PRIVATE-SSL-KEY,TRUSTED-SSL-CERT,rhn-ca-openssl.cnf}' 


this command tries to copy RHN-ORG-rhn-ca-openssl.cnf   which is just really a typo....

should be just..
rhn-ca-openssl.cnf
Comment 1 Miroslav Suchý 2009-05-28 13:06:20 EDT
Already fixed under BZ 499789

*** This bug has been marked as a duplicate of bug 499789 ***
Comment 2 wes hayutin 2009-05-28 14:27:28 EDT
this not a dupe..

This particular issue is only regarding to prepending of "RHN-ORG" to the file rhn-ca-openssl.cnf.

From what I can see in 499789 that issue is not addressed.
Comment 3 Miroslav Suchý 2009-05-29 02:42:58 EDT
It may not stated exactly in 499789, but your problem is fixed by commit 3d4c98195b6770db30d1ca240e92f781e43b4e44, which I stated in https://bugzilla.redhat.com/show_bug.cgi?id=499789#c5

But OK, will leave this one for separate validation.
Comment 4 wes hayutin 2009-06-02 11:23:00 EDT
 scp 'root@grandprix.rhndev.redhat.com:/root/ssl-build/{RHN-ORG-PRIVATE-SSL-KEY,RHN-ORG-TRUSTED-SSL-CERT,rhn-ca-openssl.cnf}' /root/ssl-build
[root@dhcp77-132 rhn]# scp 'root@grandprix.rhndev.redhat.com:/root/ssl-build/{RHN-ORG-PRIVATE-SSL-KEY,RHN-ORG-TRUSTED-SSL-CERT,rhn-ca-openssl.cnf}' /root/ssl-build
The authenticity of host 'grandprix.rhndev.redhat.com (10.10.76.46)' can't be established.
RSA key fingerprint is b3:87:97:76:37:5d:09:59:5e:e2:98:5d:50:98:ce:34.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'grandprix.rhndev.redhat.com,10.10.76.46' (RSA) to the list of known hosts.
root@grandprix.rhndev.redhat.com's password: 
RHN-ORG-PRIVATE-SSL-KEY                                         100% 1743     1.7KB/s   00:00    
RHN-ORG-TRUSTED-SSL-CERT                                        100% 5093     5.0KB/s   00:00    
rhn-ca-openssl.cnf                                              100% 2126     2.1KB/s   00:00    
[root@dhcp77-132 rhn]


verified
Comment 6 Brandon Perkins 2009-09-10 10:39:00 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.