Bug 503067 - rpm package is invalid because of missing files
rpm package is invalid because of missing files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 12:46 EDT by Larry Brigman
Modified: 2009-05-29 11:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-29 11:36:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Brigman 2009-05-28 12:46:15 EDT
Description of problem: running rpm -Vp on the package shows missing files.

rpm -Vp grub-0.97-50.fc11.x86_64.rpmUnsatisfied dependencies for grub-0.97-50.fc11.x86_64: rpmlib(FileDigests) <= 4.6.0-1
missing     /boot/efi/EFI/redhat
missing     /boot/efi/EFI/redhat/grub.efi
Comment 1 Michael Schwendt 2009-05-29 11:14:19 EDT
Not a bug.


> rpm -Vp grub-0.97-50.fc11.x86_64.rpm

You select a package file with -p but you don't show what package is installed actually (rpm -q grub). Use "rpm -V grub" or "rpm -Vv grub" or even "rpm -Vvv grub" to verify the installed package files against the RPM database.


> Unsatisfied dependencies for
> grub-0.97-50.fc11.x86_64: rpmlib(FileDigests) <= 4.6.0-1

rpm -q rpm-libs rpm

returns what?


> missing     /boot/efi/EFI/redhat
> missing     /boot/efi/EFI/redhat/grub.efi  

$ rpm -qpl grub-0.97-50.fc11.x86_64.rpm | grep efi
/boot/efi/EFI/redhat
/boot/efi/EFI/redhat/grub.efi
Comment 2 Larry Brigman 2009-05-29 11:36:47 EDT
Preparing...                ########################################### [100%]
   1:grub                   ########################################### [100%]
error: unpacking of archive failed on file /boot/efi/EFI/redhat/grub.efi;4a200004: cpio: MD5 sum mismatch


[root@sweng0224 ~]# rpm -q rpm-libs rpm
rpm-libs-4.4.2.3-9.el5
rpm-libs-4.4.2.3-9.el5
rpm-4.4.2.3-9.el5

I think I found a reference to this.  RHEL5 and others use a hash instead of
MD5.  I guess I will have to rebuild the package in my environment to
solve.

Thanks

Note You need to log in before you can comment on or make changes to this bug.