Bug 503068 - Graph fails to release upon drag-move in v. 1.8.2
Graph fails to release upon drag-move in v. 1.8.2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: goffice (Show other bugs)
11
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Robert Scheck
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 12:46 EDT by Daniel Siderius
Modified: 2009-11-11 19:56 EST (History)
6 users (show)

See Also:
Fixed In Version: 0.6.6-4.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 06:03:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 316502 None None None Never

  None (edit)
Description Daniel Siderius 2009-05-28 12:46:40 EDT
Description of problem:
In Gnumeric v. 1.8.2 (current version in fc10 repo), when a graph is moved, the graph does not release and anchor itself upon release of the mouse button.

Version-Release number of selected component (if applicable):
1.8.2

How reproducible:
Guaranteed, every time. Incredibly annoying.

Steps to Reproduce:
1. In Gnumeric 1.8.2, create a graph
2. Click and hold on graph, drag to a new position.
3. Graph will not release until a "double click"
  
Actual results:
Graph should release and anchor itself at new position upon release of mouse button.

Expected results:
Graph fails to anchor, requires double to release

Additional info:
This bug is specific to version 1.8.2, and has been corrected in version 1.8.4. It is well known in other Linux distros. See, for example, this Ubuntu bug record: https://bugs.launchpad.net/gnumeric/+bug/316502

Version 1.8.4 is available in the rawhide repo, but upgrading to 1.8.4 with the fc11 rawhide repo requires many, many other updates to fc10.
Comment 1 Luke Hutchison 2009-10-20 19:31:55 EDT
Still present in Fedora 12 beta.

Requires updating goffice, I believe.

See also https://bugzilla.gnome.org/show_bug.cgi?id=566652 .
Comment 2 Robert Scheck 2009-10-21 05:40:33 EDT
This is not a bug of gnumeric, but in goffice. The patches referenced in
comment #1 solve this issue. I'm going to apply the patches from 0.6 branch
of goffice at Fedora - this will fix the issue.
Comment 4 Fedora Update System 2009-10-21 06:06:19 EDT
goffice-0.6.6-4.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/goffice-0.6.6-4.fc10
Comment 5 Robert Scheck 2009-10-21 06:12:57 EDT
For goffice-0.6.6-4.fc12 see: https://fedorahosted.org/rel-eng/ticket/2612
Comment 6 Daniel Siderius 2009-10-23 10:40:15 EDT
When these updates be part of the YUM repositories?
Comment 7 Luke Hutchison 2009-10-23 10:54:46 EDT
I got the update for gnumeric yesterday and goffice today via the F12 rawhide channel.  The F11 channel updates hadn't been pushed as of yesterday, I imagine they will trickle in.
Comment 8 Robert Scheck 2009-10-23 11:20:32 EDT
It should arrive in updates-testing in the next days.
Comment 9 Fedora Update System 2009-11-11 19:54:31 EST
gnome-chemistry-utils-0.10.8-1.fc10.1, goffice-0.6.6-4.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2009-11-11 19:56:03 EST
goffice-0.6.6-4.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.