Bug 503073 - virt-install --disk pool= and vol= is busted
virt-install --disk pool= and vol= is busted
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 13:40 EDT by Cole Robinson
Modified: 2009-12-14 16:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 11:29:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2009-05-28 13:40:45 EDT
In version python-virtinst-0.400.3-1.el5

Example:

virt-install --connect test:///default --name foo --ram 64 --pxe --nographics --noautoconsole --disk pool=default,size=.001
ERROR    A disk path must be specified. (use --prompt to run interactively)

The above command should succeed, creating a new storage volume. This was fixed upstream several weeks ago:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/676312613510

Specifying floppy devices is new functionality introduced by the rebase, so
this technically isn't a regression (and by extension the bug hasn't existed in
any released version). However, the patch is simple, low risk, and was caught using a command line test suite upstream (so I have high confidence that the change doesn't cause unintended breakage).
Comment 1 Cole Robinson 2009-06-08 11:29:29 EDT
Fixed in python-virtinst-0.400.3-2.el5. Closing as NEXTRELEASE, since this bug has
not existed in any released package as it was brought in by the rebase.

Note You need to log in before you can comment on or make changes to this bug.