Bug 503086 - Sound does not work (ie no output)
Sound does not work (ie no output)
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jaroslav Kysela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 15:14 EDT by Hubert Figuiere
Modified: 2009-06-04 14:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-04 14:59:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa info before (18.48 KB, text/plain)
2009-05-29 11:29 EDT, Hubert Figuiere
no flags Details
output of amixer -c0 (2.06 KB, text/plain)
2009-05-29 11:34 EDT, Hubert Figuiere
no flags Details

  None (edit)
Description Hubert Figuiere 2009-05-28 15:14:10 EDT
I can't get about sound output on my laptop (ThinkPad Z60t). This has worked previously with the other distros I installed from the original Ubuntu to SUSE 11.1.

I have tried the hardware buttons (mute, up, down) without feedback or success.
The sound "applet" from pulse audio show it is unmuted and at 77%. Changing that, no dice.
Sound preferences show the application playing the music. There is only one output, internal audio and it is selected.
Gstreamer-properties, same. It also appears on the sound preferences.


One thing: when I installed F11, the sounds had been muted previously under openSUSE 11.1 using the hardware buttons. Not sure it is relevant though.

Also, I remember back when I installed Ubuntu, I had to use the gnome-mixer to enable the "Front" channel. There is not such thing visible in PulseAudio sound preferences.

Kernel is
Linux grinch.figuiere.net 2.6.29.3-140.fc11.i686.PAE #1 SMP Tue May 12 10:44:10 EDT 2009 i686 i686 i386 GNU/Linux

Audio device is:
00:1b.0 Audio device: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
Comment 1 Lennart Poettering 2009-05-29 06:59:54 EDT
Could you please have a peek on this mail from Adam:

https://www.redhat.com/archives/fedora-devel-list/2009-April/msg02321.html

And then attach the amixer outputs here, before and after trying to fix the mixer settings with "alsamixer"?
Comment 2 Hubert Figuiere 2009-05-29 11:29:24 EDT
Created attachment 345920 [details]
alsa info before

alsa info run when there is no sound.
Comment 3 Hubert Figuiere 2009-05-29 11:31:03 EDT
I just did "alsactl init" and it works.
Comment 4 Hubert Figuiere 2009-05-29 11:34:20 EDT
Created attachment 345921 [details]
output of amixer -c0

this is the output of "amixer -c0", but at that point it already works since I did "alsactl init"
Comment 5 Hubert Figuiere 2009-05-29 11:41:12 EDT
And by work I mean I had RB playing music, and suddenly, the music was in the headphones when I did "alsactl init", which is all I wanted.
Comment 6 Lennart Poettering 2009-06-04 14:59:37 EDT
Ok, if alsactl init fixed your issue, then this was simply an upgrade issue. Closing.

Note You need to log in before you can comment on or make changes to this bug.