Bug 503092 - virt-install: distro autodetection for fedora beta releases is busted
virt-install: distro autodetection for fedora beta releases is busted
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 15:40 EDT by Cole Robinson
Modified: 2009-12-14 16:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-08 11:29:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2009-05-28 15:40:54 EDT
In version python-virtinst-0.400.3-1.el5

./virt-install --connect test:///default --name foo --ram 64 --nographics --nodisks --location http://download.fedora.devel.redhat.com/pub/fedora/linux/releases/test/11-Preview/Fedora/x86_64/os/


Starting install...
Retrieving file .treeinfo...                             | 1.2 kB     00:00     
Retrieving file vmlinuz...                               | 3.0 MB     00:01     
Retrieving file initrd.img...                            |  19 MB     00:06     
OS variant 'fedora11-preview; does not exist in our dictionary for OS type 'linux'
Domain installation may not have been
 successful.  If it was, you can restart your domain
 by running 'virsh start foo'; otherwise, please
 restart your installation.
ERROR    OS variant 'fedora11-preview; does not exist in our dictionary for OS type 'linux'
Traceback (most recent call last):
  File "./virt-install", line 865, in <module>
    main()
  File "./virt-install", line 763, in main
    start_time, guest.start_install)
  File "./virt-install", line 818, in do_install
    dom = install_func(conscb, progresscb, wait=(not wait))
  File "/mnt/storage.bos/boston/crobinso/sandbox/rhel/python-virtinst/python-virtinst/RHEL-5/virtinst-0.400.3/virtinst/Guest.py", line 539, in start_install
    self._prepare_install(meter)
  File "/mnt/storage.bos/boston/crobinso/sandbox/rhel/python-virtinst/python-virtinst/RHEL-5/virtinst-0.400.3/virtinst/Guest.py", line 594, in _prepare_install
    meter = meter)
  File "/mnt/storage.bos/boston/crobinso/sandbox/rhel/python-virtinst/python-virtinst/RHEL-5/virtinst-0.400.3/virtinst/DistroInstaller.py", line 233, in prepare
    self._prepare_kernel_and_initrd(guest, distro, meter)
  File "/mnt/storage.bos/boston/crobinso/sandbox/rhel/python-virtinst/python-virtinst/RHEL-5/virtinst-0.400.3/virtinst/DistroInstaller.py", line 192, in _prepare_kernel_and_initrd
    guest.os_variant = os_variant
  File "/mnt/storage.bos/boston/crobinso/sandbox/rhel/python-virtinst/python-virtinst/RHEL-5/virtinst-0.400.3/virtinst/Guest.py", line 240, in set_os_variant
    {'var' : val, 'ty' : self._os_type}
ValueError: OS variant 'fedora11-preview; does not exist in our dictionary for OS type 'linux'


This issue is fixed via the following upstream commits:

http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/9768e52d4d62
http://hg.et.redhat.com/cgi-bin/hg-virt.cgi/applications/virtinst--devel/rev/db997572bdc8

The second patch is the most important: this protects against possible bogus autodetection in the future from preventing an install. This could be valid for e.g. RHEL5 beta installs (won't know offhand until I see the .treeinfo file).

Fix is isolated, and has passed the upstream URL fetching regression test suite, so I have high confidence it doesn't impact other code.
Comment 1 Cole Robinson 2009-06-08 11:29:13 EDT
Fixed in python-virtinst-0.400.3-2.el5. Closing as NEXTRELEASE, since this bug has
not existed in any released package as it was brought in by the rebase.

Note You need to log in before you can comment on or make changes to this bug.