Bug 503093 - Huawei 3g stick stops working when MicroSD inserted.
Huawei 3g stick stops working when MicroSD inserted.
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 15:44 EDT by Alex Hudson (Fedora Address)
Modified: 2009-11-11 12:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-11 12:45:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log messages when MicroSD _is_ inserted. (4.05 KB, text/plain)
2009-05-28 15:46 EDT, Alex Hudson (Fedora Address)
no flags Details
Successful connection when MicroSD is removed. (6.65 KB, text/plain)
2009-05-28 15:47 EDT, Alex Hudson (Fedora Address)
no flags Details

  None (edit)
Description Alex Hudson (Fedora Address) 2009-05-28 15:44:58 EDT
Description of problem:

You're gonna love this, I'm sure :)

I have a Huawei 3G stick, which "stopped working" recently. Actually what had happened was that I'd inserted a MicroSD card into it, to use as a flash stick, and with that the 3G stuff doesn't work any more.

When you insert it, it lights up as usual, and NetworkManager makes an effort. It doesn't ever connect, though.

Once I take out the MicroSD card, it works again - although sometimes won't come up automatically, but I suspect that's due to the confusion the first time around.

I'll attach some /var/log/messages excerpts for attempts with and without the flash RAM.

Version-Release number of selected component (if applicable):

NetworkManager-0.7.1-4.git20090414.fc11.x86_64
Comment 1 Alex Hudson (Fedora Address) 2009-05-28 15:46:43 EDT
Created attachment 345830 [details]
Log messages when MicroSD _is_ inserted.
Comment 2 Alex Hudson (Fedora Address) 2009-05-28 15:47:53 EDT
Created attachment 345831 [details]
Successful connection when MicroSD is removed.
Comment 3 Dan Williams 2009-05-29 14:37:15 EDT
Something to try, all as root:

1) service NetworkManager stop
2) NM_SERIAL_DEBUG=1 /usr/sbin/NetworkManager --no-daemon
3) wait a bit
4) insert the stick
5) (as your user) try to connect

Attach the stuff that NM dumps out and lets see if we can figure out why the card is unhappy.  When you've got what you need, hit Ctl+C to kill NM, then you can 'service NetworkManager start' and you'll be back to normal.  THanks!
Comment 4 Bug Zapper 2009-06-09 12:44:15 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Steven Drinnan 2009-06-18 05:03:01 EDT
Go to your phone company get them to upgrade your firmware, it fixes this problem.
Comment 6 Dan Williams 2009-11-11 12:45:43 EST
Yeah, I've heard from a couple of users that early-version Huawei devices have issues like this, so a firmware upgrade is likely the best way to go.  If your 3G provider doesn't have a firmware update available, sometimes you can find them from Huawei's site as well.

Note You need to log in before you can comment on or make changes to this bug.