Bug 503096 - preupgrade leaves old yum metadata laying around
preupgrade leaves old yum metadata laying around
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 16:06 EDT by Wolfgang Rupprecht
Modified: 2014-01-21 18:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-10 13:28:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wolfgang Rupprecht 2009-05-28 16:06:51 EDT
Description of problem:
preupgrade leaves old yum metadata laying around.  Doing a yum update shortly after a preupgrade can cause yum to try to download and install the rpm's for the last release instead of the newly upgraded to release.

Version-Release number of selected component (if applicable):
1.0.1-2.fc10 (from memory)

How reproducible:
probably always, but difficult to retest

Steps to Reproduce:
1. on f10 system: yum update
2. preupgrade
3. yum update
  
Actual results:

Yum picks up new f10 updates -- eg. from old system

Expected results:

Yum picks up new f11 updates -- eg. from new system

Additional info:

Yum did try to load the f11 respmod.xml (name from memory), but it was older than the f10 one already downloaded so it continued to use the old f10 version.

It would be good for preupgrade to do a yum clean metadata as one of the last things it does, or the installation instructions need to mention that the user needs to do this as one of the first orders of business before doing anything significant with yum.
Comment 1 seth vidal 2009-05-28 16:45:08 EDT
when you say 'preupgrade'

do you mean run preupgrade and then reboot and do the upgrade? or do you mean just run preupgrade?
Comment 2 Wolfgang Rupprecht 2009-05-28 16:50:30 EDT
Oh, sorry, I wasn't clear.  I meant preupgrade and then hit the on-screen reboot button and run the upgrade, then let it boot into the upgraded system and then do a "yum update" from the newly upgraded-to release.
Comment 3 Wolfgang Rupprecht 2009-05-28 17:00:09 EDT
That probably still wasn't very clear.  Let me try again.  After upgrading from f10 to f11 and running f11 I did a "yum update -y".  What I saw (from memory)

"repmod.xml is older than the one we have.  Using ours."

somerpm-12345.fc10
otherrpm-23454.fc10

Eg. Yum was still trying to download the fc10 rpm's instead of the fc11 ones.  After a "yum clean metadata" yum downloaded an fc11 repmod.xml and all was well.
Comment 4 seth vidal 2009-05-28 17:04:15 EDT
reassigning to anaconda - since this is something it would have to do.
Comment 5 Chris Lumens 2009-07-10 13:28:48 EDT
This should be fixed in the next build of anaconda.  Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.