Bug 503133 - "mkdir-p" should not throw errors on preexisting directories
"mkdir-p" should not throw errors on preexisting directories
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard W.M. Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-29 02:46 EDT by Charles Duffy
Modified: 2010-03-27 06:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-27 06:12:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Duffy 2009-05-29 02:46:58 EDT
On Thu, May 28, 2009 at 06:04:16PM -0500, Charles Duffy wrote:
> > To properly behave as "mkdir -p", mkdir-p should consider the case where  
> > the target directory already exists successful.
> >
> > libguestfs: error: mkdir -p: /root/.ssh: File exists

Yes, please file a bug report about that so we can track it.

Rich.
Comment 1 Richard W.M. Jones 2009-05-29 06:21:48 EDT
I think this should fix it:
http://git.et.redhat.com/?p=libguestfs.git;a=commit;h=f6e36bf361c587e0dbb2f0c71f5d22a7cf7f4f42
Comment 2 Fedora Update System 2009-05-29 09:48:41 EDT
libguestfs-1.0.37-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.37-1.fc11
Comment 3 Fedora Update System 2009-06-02 11:10:50 EDT
libguestfs-1.0.38-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.38-1.fc11
Comment 4 Fedora Update System 2009-06-04 11:40:10 EDT
libguestfs-1.0.41-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.41-1.fc11
Comment 5 Fedora Update System 2009-06-06 13:58:27 EDT
libguestfs-1.0.42-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.42-1.fc11
Comment 6 Fedora Update System 2009-06-23 05:15:54 EDT
libguestfs-1.0.51-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.51-1.fc11
Comment 7 Fedora Update System 2009-06-29 15:28:29 EDT
libguestfs-1.0.54-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.54-2.fc11
Comment 8 Fedora Update System 2009-07-02 19:27:16 EDT
libguestfs-1.0.55-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.55-1.fc11
Comment 9 Fedora Update System 2009-07-11 05:28:16 EDT
libguestfs-1.0.58-2.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/libguestfs-1.0.58-2.fc11
Comment 10 Fedora Update System 2009-07-11 13:13:37 EDT
libguestfs-1.0.54-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2009-07-19 06:28:56 EDT
libguestfs-1.0.58-2.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Richard W.M. Jones 2010-03-27 06:12:36 EDT
Seems to be fixed upstream:

><fs> mkdir-p /a/b/c
><fs> mkdir-p /a/b/c
><fs> mkdir-p /a/b/c/d/e
><fs> find /
a
a/b
a/b/c
a/b/c/d
a/b/c/d/e

Note You need to log in before you can comment on or make changes to this bug.